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MoDOT Function Key Assignments 
 
F1  -  Activates the MicroStation Help information 
 
F2  -  Activates the Civil Help information 
 
F3  -  Opens the View Attributes dialog 
 
F4  -  Closes down all currently active tools and deselects everything in the file 
 
F5  -  Toggles Off/On Constructions attributes under the View Attributes tool 
 
F6  -  Used to open View 2 in an Isometric rotation along with the Display Style representation set to 
Illustration.  Used for 3d files only.  
 
F7  -  Activates the Analyze Point tool under the Terrain Model task.  Also toggles on Civil Accudraw and 
sets the Civil Accudraw option to Station-Offset 
 
F8  -  Activates the Create Template tool under the Corridor Modeling task 
 
F9  -  Activates the Excel to MicroStation tool for importing data from the Quantab Excel sheet. 
 
F10 -  Creates a Display Set of the elements that you have selected within the file 
 
F11 -  Clears out an active Display Set 
 
F12 -  Blank 
 
 
Ctrl+F1  -  Converts the model properties for the line style scale from Global Line Style Scale to 
Annotation Scale.  It will only convert the model that is currently active. 
 
Ctrl+F2  -  Activates the Saved Views tool 
 
Ctrl+F3  -  Activates a tool to exaggerate a terrain model.  This will only work in a 3d file and it creates a 
temporary model for viewing purposes only. 

 
 
Shift+F1 -  Activates the Redraw tool under the Survey task 
 
Shift+F12 – Removes any unused fonts and compresses the file 

 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 

General Tips with PowerGEOPAK 
 

If you accidentally closed out or remove the tabs for the Tasks, Project Explorer, Element Information, etc. tools, 
these are the locations to get those tools back out to use again in PowerGEOPAK. 
 
 
 
Tasks – Go to Tools > Tasks to activate again  
 

 
 
 
 
 
Project Explorer – Go to File > Project Explorer to activate again 
 

 
 

 
 
 



 
 
 

Element Information – Go to Element > Information to activate again  
 

 
 
 
Civil Message Center – Go to Tools > Civil Geometry > Geometry Toggles > Civil Message Center to activate again  
NOTE: This is also the location for the Designs Standards Toolbar, Features Definition Toggle Bar, etc. if they are 
accidentally closes or removed from the PowerGEOPAK Interface. 
 

 
 



 
 
 

 
Civil Accudraw – Go to Tools > Civil Accudraw > Activate Toolbar to activate again  
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Instructions for after PowerGEOPAK and ProjectWise  
has been installed on your computer 

 
Once PowerGEOPAK SS4 and ProjectWise SS3 has been installed on your computer, there will be a couple items 
that you will need to do. 
 
1) Go to the Start Menu > All Programs > Bentley folder and run the PowerGEOPAK Cleanup Tool.  This tool will 

remove certain files and copy necessary files back to the computer for PowerGEOPAK to run using the default 
MoDOT settings. 
 
Follow the prompts when the tool runs. 
 
NOTE:  This tool can be ran at any time if you having issues with PowerGEOPAK not running properly.  Make 
sure you exit out to PowerGEOPAK first though before running the cleanup tool. 
  
 

. 
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2) The existing ProjectWise icon on the desktop will not work after ProjectWise SS3 has been installed.  Delete 
the icon on the desktop. 

 
Go to the Start Menu > All Programs > Bentley > ProjectWise V8i (SELECTseries 3) folder and select 
ProjectWise Explorer to access the program.   
 
If desired, you can create an icon on the desktop by right clicking over ProjectWise Explorer and select       
Send to > Desktop (create shortcut) option. 
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Instructions for Updating Existing DGN Files  
for the PowerGEOPAK Conversion 

 
With the onset of PowerGEOPAK,  a few workflows that we have come accustom to will need to change.  To 
accommodate these changes, existing DGN files will need to be modified in order for them to work within 
PowerGEOPAK.  These instructions will go through steps that need to be done to existing DGN files in order for 
those files to open and work properly in PowerGEOPAK. 
 
1) Activate ProjectWise and navigate to the project you are working on.  

 
Right click over the dgn file and select Properties.   
 
In the dialog box, select the Workspace tab.  Change the Workspace Profile to Annotation so the dgn file can 
be opened in PowerGEOPAK.   
 
Click Save to apply the changes to the file. 
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1a)  Sometime during the design process, you will also need to change the Scale option to Annotation under the 
Attributes tab.  This will allow the dgn file to process properly into a sealable Contract Plan PDF when the job 
is ready to be submitted. 

 
 

 
 
 
 
 

2) Open the dgn file. 
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3) Once the file is open, convert the Line Style Scale option to Annotation Scale under the Model properties.  Also 
toggle on the Annotation Scale in the Drawing Scale toolbox. 

 
Both of these can be easily done by clicking Ctrl+F1 on the keyboard.  It will run a command that will turn on 
Annotation Scale and change the Model properties automatically.   
Note:  If you have changed the command for the function key of Ctrl+F1, this option will not work. 

 
 
 

Another option is to go to MoDOT > Annotation Scale > Activate Annotation Line Styles to change the Model 
properties of the file.    
 

 
 

 
 
Also go and toggle on the Annotation Scale icon in the Drawing Scale toolbox. 
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4) Go the Drawing Scale toolbox and change the scale to match the scale of the border attached to the file. 
 

Note:  This is the only step you will need to do when working on newly created files.  The workspace profile 
and Model properties for annotation scale have already been configured in the seed files with the proper 
settings. 
 

 
 
 
 
5) You are finished!!!  You can begin working on the file again. 
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Tasks & Drawing Scale 
2.1 Overview of Tasks 
A task is a set of tool references grouped to facilitate a particular job. A sequence of tasks can be grouped into a 
workflow. By defining and grouping tasks into workflows, you can create a task-based user interface. The tool 
references grouped into a task can be standard MicroStation tools, custom tools, or a mixture of both types. The 
task's tool references can be grouped into standard MicroStation toolboxes, custom toolboxes, or a combination of 
both types. Therefore the interface will contain all the tools and toolboxes you need to complete your work, 
grouped the way you want them. 
 
MoDOT utilizes Tasks for the CADD Standards to enable their users to place standardize items such as line styles, 
line weights, colors, text styles, dimension styles, patterns, cells, and scales. The Tasks enables the user to place 
geometry with the correct element attributes and it will also invoke the recommended tool with a single mouse 
click. The Tasks have been broken out into 3 different groups – Design, Survey, and Bridge. 
 

 
 
Each group is then broken out into other groups to make it easy to find the correct tasks for the operation that you 
are doing at that time.  Once you select the appropriate Task, it will call up the appropriate tool to use and also 
change the attributes and/or other settings to the correct MoDOT standards. 
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2.2 Overview Drawing Scale (Annotation Scale) 

The Drawing Scale window is a dockable window that contains controls for viewing and/or modifying working 
units, the annotation scale factor, the Annotation Scale Lock, the active Auxiliary Coordinate System (ACS), ACS 
scale, and ACS scale lock. These settings are particularly relevant to the process of creating sheet models for 
drawing production. This window opens when Settings > Drawing Scale is chosen. 

 

 
Undocked Drawing Scale window 

 
 

 
Docked Drawing Scale Window 

 

 

 

 

The selection of controls displayed in the Drawing Scale window can be customized by right-clicking in the window. 
The technique is the same as that for showing and hiding tools in toolboxes. 
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For MoDOT standards, the Annotation Scale in the Drawing Scale tool has been customized to include all Design 
files scales and all Bridge file scales.  The Annotation Scale should be set to the scale of the border placed into the 
file. 
 
The Annotation Scale will control the size of cells , text, or dimensions placed and the display of custom linestyles 
(guardrail line, r/w lines, utility lines, etc.) in the file.  It can also control the size of geometry for reference files in 
the active file if necessary. 
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The exception for annotation scale for scaling everything in the file is patterns.  In the MicroStation software, 
hatching and patterns have not been configured to use annotation scale in this version.  Therefore, hatching and 
patterns have been broken out into separate groups in the Task listing that include all the scales needed.   Once 
the hatching or pattern has been applied to an area, it will stay that scale regardless of the annotation scale 
applied to the file. 
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2.3 Activating the CADD Standard Tasks 
 
The CADD Standards are activated by selecting the appropriate Tasks.  The Tasks may be broken out into Groups 
that contain tasks that are associated to that Group like CMP-RCP Pipes, Drainage, Drop Inlets, etc. 
 

 
 
Once you navigated to the proper Group, select the Task as needed.  
 
Selecting a Task with a single mouse button click will allow that item to be placed on the correct level, color and  
weight.  Using the Task also keeps the user from having to attach a cell library or look up what level items are to be 
placed so that everyone at MoDOT is placing the same cells on the same levels.  This also keeps the user from 
having to set text heights, widths and spacing.  Dimensions are also incorporated in the Task to set the correct text 
attributes, arrowhead sizes and other dimension attributes properly. 
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When viewing the Tasks under a certain group, you will see icons on the left side of the Task.  These are indicators 
that basically tell you what tool it will call up when you select that Task.  
 
Hovering over the Tasks will also show you what tool it will call up when you select that Task. 
 

  Place Note 
 

 Place Text 
 

 Dimension 
 

 Place Cell 
 

 Area Pattern 
 

 Place SmartLine  
 

 MultiLine 
 

 Place Curve 
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Tasks that are associated to the Place Text tool or the Place Dimension tool will have a style applied to that Task.  
Styles are named sets of attributes, such as font, width, height, color, arrowheads, etc. that allow you to place text 
or dimensions within a file in a consistent and automated manner. The text and dimensions styles are stored in 
read-only DGN Libraries to allow management of text attributes and dimension attributes throughout the 
department. 
 

 
 
 

 
 
 
Once a style has been used, it will embed itself in the file.  This allows the file to be easily transferred to another 
department or company that may not have our MoDOT CADD setup, like a utility company. 
 
Since styles will embed themselves in the file, the style can be modified or changed to whatever settings needed 
for that text or dimension to be placed.  These settings will stay applied to the text style or dimension, unless you 
select a certain text or dimension task.  Then it will pull the style from the DGN Library for that text or dimension 
you need to place in the file. 
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Civil AccuDraw 
3.1 Overview 
Civil AccuDraw performs many of the same functions as MicroStation AccuDraw but has greatly expanded 
capabilities for the civil designer. It allows the user to define a point location at any stage of any placement tool 
(MicroStation or other civil applications) and accepts input that results in more sophisticated point locations 
 
There are many benefits in using Civil AccuDraw.  It extends the drafting power of MicroStation by providing Civil 
point location methodologies in all the MicroStation and Civil commands.  It will also eliminate the need to create 
temporary construction geometries just to perform more complex point locations.  
 
In general, Civil AccuDraw works in a similar way to MicroStation AccuDraw. However there are some differences 
and some limitations that will be addressed in future versions. 
 
Differences 

• Smart lock (<Enter>) is not supported in Civil AccuDraw. Similar functionality is possible by key-in and 
locking a value corresponding to the compass point. 

• Spacebar does not switch Civil AccuDraw modes. It opens the mnemonic pop-up which provides similar 
and additional functionality. 

• O shortcut is subtly different. MicroStation AccuDraw reads the cursor position at the instant that O is 
pressed. Civil AccuDraw waits for a DP. In addition, in Civil AccuDraw, the O shortcut also serves to pick 
the base element for station or offset ordinates. Once chosen this element is remembered for the 
duration of the session or until changed by user. 

• In Civil AccuDraw, the delta Z origin can be set independent of the XY origin. 
• When in a 3D model, the Civil AccuDraw compass always considers X, Y and Z as separate and distinct. For 

example, using Civil AccuDraw in a side view, the Y and Z ordinates will dynamically track values. On the 
other hand, MicroStation AccuDraw would still call the ordinates X and Y even though in a side view. 
Keeping the ordinates distinct and separate lays the groundwork for future enhancements where other Z 
ordinates such as slope will be introduced. 

 
Limitations 

• Simultaneous use of Civil AccuDraw and MicroStation AccuDraw will cause errors. 
• Switching between Civil AccuDraw and MicroStation AccuDraw while values are locked may cause errors. 
• Angle input: 

The use of d, m and s for degree, minute and seconds delimiters is not supported. 
Input angle in the form DD^MM.mm is improperly interpreted as DD^00’MM.mm”. 

• Stationing:Station-offset using a closed B-spline may be incorrect. Civil AccuDraw cannot consume the 
stationing on alignments stored in GPK, ALG nor FIL files. The graphical elements representing these 
alignments can be selected but Civil AccuDraw will interpret the starting station as zero. 

• When using Civil AccuDraw and viewing the shortcuts list, there may be shortcuts listed which have no 
function in Civil AccuDraw. Civil AccuDraw shares the shortcuts.txt file with MicroStation AccuDraw and 
some of the shortcuts are not relevant or have not been implemented in Civil AccuDraw. 

• In the shortcuts list, if ordinates are station-offset and you choose Set Origin, clicking Run has no effect. 
• Alternate Coordinate Systems (ACS) are not recognized by Civil AccuDraw. 
• Civil AccuDraw will override DGN Settings > Grid Lock. This is by design. Toggle Civil AccuDraw off if the 

grid lock function is required. Similar functionality can be achieved within Civil AccuDraw by setting the 
round off values in Civil AccuDraw settings. 
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3.2 Working with Civil AccuDraw 
 

Activating Civil Accudraw 
By MoDOT default, the Civil Accudraw toolbar is active and located at the bottom on the MicroStation window. 
 

 
 
The toolbar can also be activated by going to Tools > Civil Accudraw > Activate Toolbar. 
 
To activate Civil Accudraw, toggle on the Civil Accudraw icon.  
 

 
 
Note:  It is advisable to disable MicroStation AccuDraw if you are using Civil AccuDraw. This is to avoid confusion 
between the functionality of the different tools. 
 
As much of the functionality is similar between Civil AccuDraw and MicroStation AccuDraw, consult this help in 
conjunction with MicroStation help for further details. 
 
 
Coordinate Display 
The coordinates of the current cursor position are displayed by default in a floating dialog. You can switch between 
the floating or fixed dialogs using the up and down arrow keys. The contents of the dialog will depend upon the 
current ordinate system selected. For example, the default system of Distance and Direction will display distance 
and angle. If the model is 3D, Z will also be displayed. 
 
Only one dialog is displayed at a time. 
 
Floating Dialog 
The floating dialog is displayed close to the current position of the cursor. As the cursor moves, the dialog moves 
and is automatically updated with the new coordinate information. Press the down arrow to switch to the fixed 
dialog. 
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Fixed Dialog 
The fixed dialog is a normal dialog and can be repositioned or docked. As the cursor moves, the dialog is 
automatically updated with the new coordinate information. Press the up arrow to return to the floating dialog. 
 
Fixed Dialog versus Floating Dialog 
The default operation of Civil AccuDraw is with a floating dialog at the cursor for feedback and input of ordinate 
values as shown below. 
 
 
 
 

 
 
 
Pressing the down arrow or the appropriate quick drop-down icon on the keyboard switches to a fixed dialog. 
 

 
 
The up arrow or quick drop down can toggle back to floating dialog. 
 
 
 
Compass 
The center of the compass indicates AccuDraw's origin point. The Civil AccuDraw compass is only displayed when 
Civil AccuDraw is active. It can also be disabled in Settings > Operation tab. 
 
The compass is always circular and is marked by a number of tics. The default is 4 compass points, this can be 
changed in Settings > Operation tab. 
 

Floating 
 

North Arrow 

Compass 



 

4 
 

 
 
 
Compass Shortcuts 
The compass can be rotated with the V, B, T, RQ, RE shortcuts. The north arrow on the compass will always point 
to north as defined in Settings > Design File > Angle Readout. 
 
If the Civil AccuDraw settings have context sensitive turned on, then the compass auto-rotates in a similar fashion 
to MicroStation AccuDraw: 
 
 

 
 
Note that rather than Direction being shown, the label and value are now an angle. This is because the context is 
based on the direction of the preceding line segment rather than an absolute direction. 
 
Use the T (Top) shortcut or the corresponding drop-down to return to a pure direction. 
 
 

 
The angle/direction settings used in Civil AccuDraw are taken from the DGN settings. See Settings > Design File 
Settings > Angle Readout category topic of MicroStation help. 
 
 



 
 
 

5 
 

Tips when using with MicroStation or Civil Geometry tools 
• Selecting the Tab key while in an entry field will change focus. 
• Selecting Enter will set the value in the field and lock it 
• Selecting the End key will unlock the field 
• Selecting the Left or Right Arrow key will move through the favorite options. 
• Selecting the Down key will bring up the associated command entry dialog in addition to the heads up 

display. 
• Selecting the Up key will remove the command entry dialog and just display the heads up display. 
• Selecting the O key will allow to select a reference element or point for using certain civil accudraw 

commands like Station-Offset, Offset-Offset, Distance-Distance, etc. 
• To input a Bearing in the direction field for civil accudraw, the following are valid forms: 

• 12:34’56 
• 12:34’56” 
• 12:34:56 
• 12^34’56” 

 
 
 

3.3 Civil AccuDraw toolbar 
This tool box consists of a icons to toggle Civil AccuDraw and access the Civil AccuDraw commands. 
 

 
 
Toggle Civil Accudraw 
To activate or deactivate Civil Accudraw 
 

 
 
Civil Accudraw Settings 
To access the Civil Accudraw settings dialog.  See Civil Accudraw 
Settings section for more information. 
A quick drop-down menu will be display when holding down the left 
mouse button over the icon.  This provides access to many Civil 
Accudraw shortcuts. 
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DX - DY 
To set the order of ordinate entry to the difference in X coordinate then the difference in the Y coordinate, with 
both sharing the same common point of origin. 
 
 

 
 
X-Y 
To set the order of entry based on absolute X-axis  and Y-axis, with both sharing the same point of origin. 
 
 

 
 
Distance & Direction 
To set the order of ordinate entry to distance then direction, with both sharing the same point of origin. 
 
 

 
 
Distance & Direction Unlinked 
To set the order of entry to distance for the first ordinate then direction for the second ordinate, without a 
common point of origin. 
 
 

 
 
Distance & Distance 
To set the order of entry to distance for the first ordinate then distance for the second ordinate, without a 
common point of origin. 
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Station & Offset 
To set the order of ordinate entry to station identification then offset value, with both sharing the same point of 
origin. 
 
 
 

 
 
Delta Station & Offset 
To set the order of ordinate entry to station identification based off a XY coordinate then offset value, with both 
sharing the same point of origin. 
 
 
 

 
 
Direction & Direction 
To set the order of entry to direction for the first ordinate then direction for the second ordinate, without a 
common point of origin. 
 
 
 

 
 
Offset & Offset 
To set the order of entry to offset for the first ordinate then offset for the second ordinate, without a common 
point of origin. 
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3.4 Civil Accudraw Coordinate Systems 
 
Horizontal Ordinates 
With MicroStation AccuDraw, the user is limited to X-Y (rectangular) or Distance-Direction (polar) coordinate 
systems. With Civil AccuDraw, the user may define an ordinate system from virtually any combination of the 
following ordinates. 
 
Note: Some combinations are not allowed simply because they do not make sense. For example: Dx - Dx 
 
X: Absolute value of X coordinate 
Y: Absolute value of Y coordinate  
Dx: Delta X (change in X) from compass origin 
Dy: Delta Y (change in Y) from compass origin 
Distance: Horizontal distance from the compass origin 
Direction: Direction (as per Settings > Design Settings > Angle Readout) from the compass origin. 
Station: The distance measured along an element. Any graphic linear element may be used. Use the Origin 
shortcut to choose the element. 
Offset: The distance measured perpendicular from an element. Any graphic linear element may be used. Use the 
Origin shortcut to choose the element. 
 
 
Sample Systems 
Some examples of ordinate systems that may be useful: 

• X-Y 
• Dx-Dy from same origin 
• Dx-Dy from different origin 
• Distance-Direction from same origin 
• Distance-Direction from different origins 
• Distance-Distance 
• Station-Offset from same or different base elements 
• Offset-Offset 
• Direction-Offset 
• Distance-Station 
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Angle Syntax 
The input for angle and direction fields follows the MicroStation Settings > Angle Readout settings. 
 
Valid forms 
Valid forms for the various settings are as follows: 
 
DD.DDDD, Radians or Grads - Use the customary decimal input. 
DD MM SS or DD MM - The following delimiters are supported between degrees, minutes and seconds: 

• Colon - For example DD:MM:SS 
• ^ (caret) to designate degrees, minute (’r;) and second (”r;) - For example DD^MM’SS” 

 
The following are not supported in the current version: 

• A space between degrees, minutes and seconds because space launches the Civil AccuDraw popup menu 
• Use of d, m and s to designate degrees, minutes and seconds. 

 
Examples 
The following are all valid forms for 12 degrees, 34 minutes, 56 seconds: 

• 12:34’56 
• 12:34’56” 
• 12:34:56 
• 12^34’56” 

 
 

3.5 Civil Accudraw Settings 
 
There are various Civil AccuDraw settings to enable you to customize the functionality and appearance of the Civil 
AccuDraw tools. 
 
You can open Settings by selecting the icon from the Civil AccuDraw tool box. 
 

 
Operation tab 
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Auto Load 
On:  Civil AccuDraw starts when MicroStation is loaded. 
 
Note:  It is highly recommended that MicroStation AccuDraw is set to NOT auto load if Civil AccuDraw is used. 
 
Floating Origin  
On:  the origin moves to the last point placed. 
Off:  the origin remains fixed. 
 
Context Sensitivity  
On:  the compass rotates in response to the context of various tools. 
Off:  the origin remains fixed 
 
Smart Key-Ins 
On:  Civil AccuDraw interprets a number as positive or negative, depending on the direction of the pointer from 
the compass. 
XY ordinates only:  Smart Key-ins cause Civil AccuDraw to move the focus to either the x or the y field depending 
on the pointer position. 
 
Preserve Method Locks 
On:  the locked values remain locked after switching the ordinate methods. For example, using station-offset 
ordinates and a lock station of 1+00, switch to distance-direction ordinates. Station 1+00 will remain locked while 
inputting distance-direction. The resulting effect will be a distance-direction-station lock. 
 
Sticky Z Lock 
On:  inputs to Z ordinates remain locked (sticky) until they are changed. This is useful in a 3D DGN to control the Z 
ordinate. For example, input 100.00 for the Z ordinate and the value remains constant until changed. 
Off:  the Z ordinate follows the cursor dynamics. 
This also controls whether the origin for delta Z measurements follows the XY origin or is independent of XY. 
 
On:  the origin for delta Z is completely independent of the XY origin. For example, the user can set the origin for 
dXdY measurements from point A and set dZ to be measured from a second point B. The Z origin does not change 
until reset by the user. The effect will be apparent when drawing a linestring. When drawing a linestring, the 
dynamic orientation of the compass will adjust to align with the most recent line segment. The Z origin will remain 
fixed wherever the user placed it at in the beginning. 
 
Note:  When Accudraw ordinates are set to X,Y the sticky Z toggle does not apply. This is because, by definition, XY 
mode is always assumed to be absolute. 
 
Always Show Compass 
On:  the compass is always visible. 
Off:  the compass is only visible when the appropriate input is required. 
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Display tab 
 

 
 
Compass 
X Axis: Sets the color of the positive X axis tick mark on the compass. 
Y Axis: Sets the color of the positive Y axis tick mark on the compass. 
Fill:  Sets the fill color of the compass circle. 
Points:  Sets the number of compass points indicated by tic marks.  In addition to tic marks, the axis locks are also 
honored on the tic marks. 
 
Constraint Dynamics 
Show Constraints:  Shows dynamic feedback for the ordinate systems in use.  For example, with Distance-Direction 
ordinates a circle indicating distance and a line indicating direction is displayed. 
Standard:  The color of the constraint dynamics. 
Hilite:  The color of constraint dynamics when they are constrained by an axis lock. 
Locked:  The color of the dynamics when they are locked by a user key-in. 
 
 
Coordinates tab 
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Unit Round-off 
Defines a stepping value so that ordinate values are rounded to an even increment. Separate round off values are 
available for distance, angle, station and offset. The distance value also affects coordinates. Check the tick box 
beside each setting to enable it. 
 
Indexing  
Axis:  If ON and if you get close to a compass point then the Civil AccuDraw dynamics lock onto the compass point 
direction. 
Distance:  If ON and if you get close to a recall distance then the dynamics lock to the recalled value. 
Tolerance:  For indexing, how close the cursor must be to the item in question when the indexing takes effect 
 
 
 
Favorites tab 
 

 
 
The Favorites tab allows for the configuration of the most commonly used ordinate systems.  It is one of the primary 
differentiators between Civil AccuDraw from MicroStation AccuDraw.    The favorite selected determines what input 
fields are available during the placement of an element. 
Most logical combinations of ordinates are allowed. See the section Civil Accudraw Coordinate Systems > 
Horizontal Ordinates for an explanation of the ordinate types. 
 
Name:  The user defined name of the designated coordinate system 
 
Ordinate 1:  The type of ordinate set for the first ordinate. (Available ordinates are X, Y, Distance, Direction, 
Station, Offset, Dx, Dy) 
 
Ordinate 2:  The type of ordinate assigned to ordinate 2. 
 
Common Origin:  If YES, the two ordinates have the same origin.  If NO, the two ordinates are measured from 
different origins.  For example, for a Station-Offset ordinate system where Common Origin is set to YES, the station 
and offset are both measured from the same alignment.  If NO then the station is measured from one alignment 
and the offset is measured from a different alignment. 
 
Icon:  The icon displayed on the Civil AccuDraw tool box. Usually a suitable icon is selected automatically, but you 
can define any icon. 
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Key  Description  

<Left/right arrow 
keys>  

Cycles through a list of options for field in focus.  

<Down arrow>  Expand to fixed dialog and suspend dynamics.  

<Up arrow>  Collapse floating dialog and resume dynamics.  

<Tab>  Advance to next input field in panel  

<Shift><Tab>  Return to previous input field in panel  

<Enter>  Locks the value after entering a key-in value. Pressing <Enter> when a value is already locked 
will increment the value.  
 
Note: Due to differences in MicroStation AccuDraw and Civil AccuDraw <Enter> does not 
provide smart lock. Use LI shortcut instead.  

<End>  Unlocks the current locked value.  

<Shift><End>  Clear all locks  

<Space>  Opens the quick pop-up tool box which is a duplicate of the quick drop-down tool box items 
except in an on-the-fly context.  

O  Choose base element for Station and Offset ordinates. Civil AccuDraw waits for a DP before 
accepting a point. (See Differences)  

V  Set compass rotated with positive Y axis up the screen  

T  Set compass rotation oriented to north  

F  Not currently supported. Sets compass orientation to front  

S  Not currently supported. Sets compass orientation to side  

B  Set compass to base rotation. Same as V unless a custom compass rotation has been previously 
set with RQ or RE. In this case B returns compass rotation to the stored RQ or RE rotation.  

E  Not currently supported. Cycles compass rotation.  

X  Locks the X ordinate value  

Y  Locks the Y ordinate value  

Key-in: civilcoord lock y  

Z  Locks the Z ordinate value  

D  Locks distance ordinate value  

A  Locks angle ordinate value  

LI  Toggles lock index. If ON, and the cursor is within tolerance, the directions will lock onto the 
nearest compass tic and distances will lock at a previous recalled distance. If OFF, neither of 
these locks are active.  

RQ  Not currently supported. Provides quick rotation of the compass to a dynamically selected 
orientation.  
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Key  Description  

RE  Orients the compass to an element.  

RV  Rotates the view to match the current compass rotation 

RA  Not currently supported.  

RC  Not currently supported.  

RX  Not currently supported.  

RY  Not currently supported.  

RZ  Not currently supported.  

?  Show shortcuts 

~  Not currently supported.  

GT  Go to tool settings. (MicroStation > Settings > Tool Settings.) Forces focus to the dialog of the 
active tool. Moving the cursor switches focus back to Civil AccuDraw.  

GK  Open the Key-in dialog  

GS  Open Civil AccuDraw Settings 

GA  Not currently supported.  

WA  Not currently supported.  

P  Data Point Key-in  

M  Multi Point Key-in  

I  Intersect Snap  

N  Nearest Snap  

C  Center Snap  

K  Snap Divisor  

HA  Civil AccuDraw on hold.  

HS  Toggle AccuSnap  

HU  Not currently supported.  

Q  Quit Civil AccuDraw  
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Models 
4.1 Overview 
When you draw or place elements in a DGN file, you are creating a model. A model is a container for elements. It 
can be either 2D or 3D, and is stored as a discrete object within the DGN file. It may be helpful to think of a DGN 
file as a stack of papers, with each paper being a model.  
 
When you first create a new DGN file from one of the seed files, this provides the empty container setup with a 
default model ready for you to create your design. If you use a 2D seed file, then the default setup is 2D, while a 3D 
seed file defaults to a 3D setup. In either case, you can create both 2D and 3D models in the open DGN file. 
Every model has its own set of eight views. The model whose views are displayed or available for display at a given 
time is the active model. 
 
You can create three types of models — design, sheet, and drawing.  The Sheet model option is not supported in 
the MoDOT Environment.  This is due to when the creation of contract plans pdf files are created through 
ProjectWise, it will only read the top model in the Model dialog listing for creating the pdf file. 
 
• Design model — consists of design geometry and can be either 2D or 3D. A design model can also be used as a 

reference or placed as a cell. By default, the view windows of a design model have black backgrounds. 
 
• Sheet model — (NOT supported in the MoDOT Enviroment) a type of model that serves as an electronic 

drawing sheet. It typically consists of design model references that are scaled and positioned to create a 
printable drawing. By default, the view windows of a sheet model have white backgrounds. 

  
• Drawing Model — a subset of a 2D or 3D design model, used to apply annotations, dimensions, callouts, and 

other embellishments to a design. By default, the view windows of a drawing model have gray backgrounds.  
 
Using the Models dialog (File > Models), you can create and switch quickly between models in a DGN file. 
 
Alternatively, you can use the View Groups window to rapidly switch between models visited in the current design 
session. These can include models in other DGN files. 
 
 

4.2 Models dialog 
Used to create, manage, and switch between models in the open DGN file. It will open when File > Models is 
chosen or when the Models icon in the Primary Tools toolbox is clicked. 
 
Each DGN file contains one or more models, each of which has its own set of eight views. You can create a model 
as a 2D or 3D Design type, as a 2D Drawing type or as a 2D or 3D Sheet type. Sheet models let you attach 
references to create a set of working drawings for the model file. Icons at the top of the Models dialog give you 
access to its various functions. 
 
 
 
 
 
 
 
 
 
 
 



 

2 
 

 
 

To Select in Models dialog 

 
Displays the models in the active design file. Click the down arrow and select Active 
Link Tree to see the available link sets. 
 

 

Models in Active Design 
File 

Opens the Create Model dialog, which lets you create a new model in the open DGN 
file 

 

New 

Opens the Copy Model dialog, which lets you make a copy in the open DGN file of the 
model selected in the list box. 

 

Copy 

Opens the Model Properties dialog, for the model selected in the list box. This dialog 
is used to modify properties of models contained in the open DGN file. 

 

Edit 

Deletes the model selected in the list box.  

Delete 

 
Opens the Import Model From File dialog, which is similar to the Open dialog. This lets 
you select a DGN or DWG file from which to select the model to import. After clicking 
OK, the Select Models dialog opens from which you can select the model to import 
into the open DGN file. 
 

 

Import 
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The “Lists area” will lists the models in the open DGN file. An icon displays next to the model name indicating 
whether the model is 2D or 3D. You can edit the model name and description by triple-clicking on the selected 
model name in the list box. To copy, delete, or adjust properties of a model, you must first select it here. Double-
clicking a model here makes it the active model. 

You can customize the columns displayed in the list box by right-clicking in the title row of the list box and using 
the menu to select which options are displayed. Items that can be displayed are: 

• Type — Icon signifying a Sheet, Design, or Drawing model. 
• 2D/3D — Icon signifying a 2D or 3D model. 
• Name — Name of model. 
• Description — Description for model. 
• Is Cell — If checked, the model can be placed as a cell 
• Cell Type — If a cell, the type of cell. 
• Is Annotation Cell — If checked, model is an annotation cell. 
• Design File — Location and name of DGN file. 

 
 
 
 
 
 
 

4.3 View Groups dialog 
The View Groups dialog is used to manipulate view groups and view windows and to navigate between models 
that have been active at some point during the current design session. 
 

 

A view group is a named collection of eight view windows that allows you to set up your desktop to display your 
preferences, including number of open view windows, window size, and view orientation. Most commonly, each 
view group is associated with a model, making it easy to access and navigate through different models in the active 
DGN file, via the View Group drop-down menu. 
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You can also associate different models to the same view group by creating multi-model view groups. Multi-model 
view groups allow you to view more than one model or saved view from the same DGN file in separate views. You 
can create a view group that displays from one to eight different models. 

Where, during a design session, you activate models in more than one DGN file, you can also use the View Groups 
window to easily navigate the current session's model history in multiple files. That is, you can switch between 
models you have activated, regardless of the files in which those models reside. 

 
 

To Select in View Groups 

 
Lets you access the previous model in the session history by clicking the left arrow. 
Alternatively, you can click the down arrow and select a previously accessed model from 
a drop-down list. 
 

 

Previous 

Lets you access the next model in the session history by clicking the right arrow. 
Alternatively, you can click the down arrow and select the next model from a drop-down 
list 

 

Next 

Clicking the down arrow displays a drop-down list of all models accessed, from which 
you can select a model to open. 
 

 

All Models Visited 

This field displays the name of the view group as well as the model with which it is 
associated. 
The option menu allows you select a different view group.  
 

 

View Group Listing 

Opens the Manage View Groups dialog, which is used to create, edit and delete view 
groups. 
 

 

Manage View Groups 

 
Click the numbered buttons to open or close individual view windows (equivalent to 
choosing the numbered items in the Window menu's Views submenu.) 
 

 

View Toggles 

  

 
For more information about Models, please refer to the PowerGEOPAK help documentation (F1) or contact CADD 
Support. 
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Geographic Coordinate Systems 

5.1 Overview 

• Understand the use of the Geographic Tools and how they can be utilized in a MicroStation file.  

5.2 Geographic Toolbar 

 

 
 
 
 
 
 
 
 
 
 
 
The Geographic Toolbar contains tools for interacting with a Global Positioning System (GPS) or Google Earth.  
This toolbar can be accessed from the Tools >> Geographic pull down in MicroStation.  It can also be accessed in 
the MoDOT Main toolbar. 
 

 
 
 
 

5.3 Select Geographic Coordinate System  

This tool is used to open the Geographic Coordinate System dialog, which is used to select a geographic coordinate 
system (GCS) from a library of predefined geographic coordinate systems. 

 

Select Geographic Coordinate System 
 Global Positioning System (GPS) 

 
Export Google Earth (KML) File 
 Capture Google Earth Image 

 Define Placemark 
 

 
 

Follow Google Earth View 
 Synchronize Google Earth View 

 

Google Earth Settings 
 

Play Camera Animation in Google Earth 
 

Open Location in Google Maps 
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5.3.1 Details 

This tool opens the Geographic Coordinate System Properties dialog box.  It is used to display the properties of a 
geographic coordinate system (GCS) that is attached to the MicroStation file. 

 

Details 
 

From Library 
 

From Placemarks 
 

From Reference 
 

From File 
 

To Reference 
 

Edit Reprojection Settings 
 

Delete Geographic Coordinate System 
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5.3.2 From Library 

This tool is used to select a geographic coordinate system (GCS) from MicroStation's library of predefined 
geographic coordinate systems. 

This is useful when: 
• Existing data was drawn in a geographic coordinate system (for example a state plane or country grid 

coordinate system) and you want to make MicroStation aware of that GCS. 
• Data is correctly drawn in one specified GCS, but you want to reproject that data to a different GCS. 
• You want to designate the GCS for a new design file. 

CADD Support has provided groups called MoDOT Geographic Coordinate Systems, Modified Geographic 
Coordinate Systems (NAD 83, and Modified Geographic Coordinate Systems (NAD 83\2011) which contain the 
most commonly used coordinate systems for MoDOT projects, depending on the district boundaries. 

 

For projects that use a “modified” coordinate system instead of the standard coordinate system or “county wide” 
coordinate system, you will need to copy and modified the standard coordinate system to match the applied 
projection factor (grid to ground factor) for the project.  These “modified” geographic coordinate systems will 
saved to the User Defined Coordinate Systems folder for future use. 

5.3.3 From Placemark 

This tool allows you select a GCS defined by placemarks when using structure-centric coordinate systems. 
Geographic placemarks, cells containing a name, longitude, latitude, and altitude, indicate the geographic 
positioning of your design. The longitude, latitude, and altitude fields specify the geographic position relative to 
the WGS 84 datum, which is the datum reported by GPS devices and also used by Google Earth. The corresponding 
position in the design file is specified by the placement point of the cell. The scale and rotation of the cell does not 
affect its meaning as a geographic placemark. 
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At least two placemarks are required to calculate this GCS and should span the entire range of interest. Placemarks 
are created using the Define Placemark Monument tool. 

A Geographic Coordinate System calculated from placemarks is only as accurate as the placemark data used to 
calculate it. If you use a calculated GCS to reference other geolocated designs, errors could be cumulative. 
Therefore, treat measurements between features in referenced designs as approximate. 

5.3.4 From Reference 

This tool is used to assign the GCS of an attached reference to the active model. You can use references to orient 
your active model when the attached reference has a standard GCS specified and has not been scaled or rotated, 
or when a reference with a computed Azimuthal Equal Area GCS is attached without scaling (it can be moved 
and/or rotated). 

If a geographic coordinate system, with an attached reference, has a geographic referencing mode turned on, the 
reference cannot be used as a source for the GCS. Its position is calculated from its GCS and the active model´s 
current GCS so selecting it as a source will not change the current GCS. The Comment column provides the reason 
a particular attachment cannot be used as a GCS source. 

5.3.5 To Reference 

 

This tool is used to set the geospatial coordinate systems (GCS) of attached references based on the GCS of the 
active model. If the GCS is selected from the standard library, it can be used to set the GCS for coincident, 
unscaled, and unrotated reference attachments. If the GCS is calculated from placemark monuments, it can be 
used to set the GCS for unscaled references. 
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5.3.6 From File 
This tool allows you to apply a GCS from a model in another design file to your current file, even if it is not attached 
as a reference. 
 

5.3.7 Edit Reprojection Settings 

This tool is used to specify the settings for reprojection. The tabs let you set the reprojection settings differently 
for references and for the active model. 

 

5.3.8 Delete Geographic Coordinate System 

This tool deletes the geographic coordinate system attached to a MicroStation file.   

It does not delete the geographic coordinate system from the MoDOT Geographic Coordinate Systems library or 
the MicroStation predefined library. 
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5.4 Global Positioning System (GPS)  

This tool is used to access a Global Positioning System (GPS) connected to your computer.   

 

 

5.5 Export Google Earth (KML) File 

This tool is used to export MicroStation geometry into a file format (KML) that Google Earth can use to see the 
MicroStation geometry. 
 
The settings that affect the export of a model are contained in the Google Earth Tools Settings dialog. 

The geometry is exported as WYSIWYG (what you see is what you get). That is, the view attributes and level 
settings are taken from the active view. If Render Mode is set to From View, in the Google Earth Export Settings 
dialog, then the display mode also is taken from the active view. It is, therefore, important to set up the view as 
you would like it to display in Google Earth. Output should be minimized to include only necessary data. The 
display of unnecessary levels should be turned off. If text and dimensions are to be excluded from the output file 
then their view attributes should be disabled.  

Typically, Wireframe display mode is appropriate for 2D models, while for most 3D models it is desirable to set the 
output display to Smooth. 

 
 
 

5.6 Capture a Google Earth Image 

This tool will capture a Google Earth image that can be utilized in a MicroStation file.   You can only use this option 
in a 3d MicroStation file. 
 
 
 

5.7 Define Placemark Monument 

This tool is used to associate a geographical location to a Monument point in a model.  

Placemark monuments are simply cells named “KmlPlacemark” with enter-data fields that display the name, 
longitude, latitude, and altitude of the monument. The origin of the cell represents the location of the placemark 
in the model. Multiple placemarks may be entered, and you can use the Active Scale setting to control the size of 
the placemark cells.  
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5.8 Synchronize Google Earth View 

This tool is used to have Google Earth navigate to the current MicroStation view. If Google Earth is not open when 
the tool is used, it will be opened automatically.  

As Google Earth supports only a limited camera model with a fixed lens length and restricts the camera to pointing 
downward only, the Google Earth views will not always match the MicroStation view exactly, but should provide a 
relatively good approximation for most views. 

 

5.9 Follow Google Earth View 

This tool is used to match the active MicroStation view to the current Google Earth view location. This tool works 
only if the model's view location is geographically close to the current Google Earth location. 
 
 
 

5.10 Google Earth Tool Settings 

This tool is used to control the settings and operation of the Google Earth tools.  These options determine how the 
KML gets created from the MicroStation drawing and if Google Earth opens after exporting the MicroStation 
geometry to the KML file. 
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5.11 Play Camera Animation in Google Earth 

This tool is used to play a camera animation in Google Earth. 
Camera animations only, are supported. 

After you have created a camera animation, you need only to geo-locate your model in some way, such as by 
defining a Placemark. There is no need to export geometry to Google Earth. 

 

5.12 Open Location in Google Maps 

 

This tool is used to open Google Maps with the selected location in the center of the map. When you enter a data 
point, the location is opened in the Google Maps web site in the browser.  
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