Chapter 2

Survey Introduction

2.1 General Concepts .............................................................................................................. 2-2
  2.1.1 Interface ..................................................................................................................... 2-2
2.2 Create a New Field Book ................................................................................................. 2-6
2.3 Creating Terrain Model ..................................................................................................... 2-9
  2.3.1 Create Terrain Model from a Field Book ................................................................. 2-9
  2.3.2 Create Terrain Model Based on Field Book Selection Set .................................... 2-9
  2.3.3 Export Terrain Models ............................................................................................. 2-10
2.4 Exporting to Geometry ..................................................................................................... 2-11
2.5 Exporting to DGN Graphics ............................................................................................. 2-12
2.6 Project Explorer - Survey Tab .......................................................................................... 2-13
  2.6.1 Default Branch ............................................................................................................ 2-13
  2.6.2 Survey Data (Field Books) Branches in the Data Tree ........................................... 2-13
  2.6.3 Filters Branch ............................................................................................................. 2-14
  2.6.4 Edit Feature Tools ..................................................................................................... 2-17
  2.6.5 Report Crossing Features Tool ................................................................................ 2-19
2.7 Group Exercise #1 – Importing the first REC file: ....................................................... 2-20
2.8 Group Exercise #2 – Importing additional REC files: .................................................. 2-57
2.9 Individual Exercise #3 – Importing additional REC files: ............................................. 2-77
2.10 Appendix: Details Panel - Point & Linear Feature Renaming ........................................ 2-90
2.11 Appendix: Bentley Point Coding .................................................................................... 2-93
2.1 General Concepts

The Survey Processing toolset provides user-friendly functions that compile disparate data sources employed in the civil design process. The primary goal of the Surveys toolset is the creation of an existing Terrain Model and to produce topography graphics.

All Survey data is stored in the active DGN Model and can be exported to various file formats as required.

Recommendations for Usage:

1. It is strongly recommended that all Survey usage occur in a 3D DGN Model. Some tools require the 3D Model to operate as expected.

2. Also, it is strongly recommended that all MicroStation DGN levels specified in your Feature Definition Library are already created prior to loading raw survey data via the Survey tools.

2.1.1 Interface

Survey tools are invoked from the Survey Processing tasks group or from the Tool > Survey menus.

The interface opens to a Project Explorer and a Survey Details panel.  
**Note:** The panels can be docked, docked and pinned, or remain floating per your preference.
Project Explorer

To access the *Project Explorer*, select the **Project Explorer** icon from the *Survey Processing* tasks group. You can also access the Project Explorer by selecting **File > Project Explorer** from the MicroStation menus.

The *Survey* tab of the Project Explorer organizes information into logical groupings for ease of use and superior visibility.

- Right-click on tree elements (branches) to access content sensitive commands.

Survey Details Panel

To access the *Survey Details* panel, select the **Show Details** icon from the *Survey Processing* tasks group. The Survey Details panel presents information associated with the item that is currently selected in the Survey tab of the Project Explorer.
In the Survey Details Pane if you select a row or rows of points you can do the following:

1) **Edit Selected items**

   - Edit selected items
   - View
   - Selection
   - Export selected items...
   - Create Control Points from selected items
   - Edit Observations
   - Media files
   - Report on selected items
   - Delete selected items
   - Reset Details

2) **View**

   - Edit selected items
   - View
   - Selection
   - Export selected items...
   - Create Control Points from selected items
   - Edit Observations
   - Media files
   - Report on selected items
   - Delete selected items
   - Reset Details
   - Turn Off Locator
   - Turn Off Auto Center
   - Center selected item
   - Fit selected item

3) **Selection**

   - Edit selected items
   - View
   - Selection
   - Export selected items...
   - Create Control Points from selected items
   - Edit Observations
   - Media files
   - Report on selected items
   - Delete selected items
   - Reset Details
   - Create selection set
   - Select from selection set
   - Emphasize selected items
   - De-emphasize all
4) **Export Selected Items**

5) Other Survey Pane Point options:
   a. Edit Observation
   b. Media Files
   c. Report on Selected items
   d. Delete Selected Items
   e. Reset Details
2.2 Create a New Field Book

To create a new Field Book, right-click on the Field Books item in the Survey tab then and select New.

- Note: To change the name of a Field Book, select the Field Book on the Survey tab and then open the Element List tab of the Survey Details panel using the Show Details tool. Select the Name cell of the Field Book Name you want to rename and type in the new name. The new Name will appear on both the Survey tab and the Name cell of the Survey Details element list.

Add Control Points

If control points are contained in a standard CTL file, drag and drop the file onto the Survey tab. This will add the control points to the project.

- Alternatively, CTL files (or any file type) can be added by right-clicking on the Field Book in the Survey tab and selecting Load > File. Navigate to the desired CTL file and then double-click it.

  o Note: If you load a file with an ambiguous file extension, you will be prompted to identify that file's format. Choose from the available options on the Data Format dialog and click Accept.

In the process of loading raw data, the system performs the following actions:

- Reduces the raw data to produce point features and linear features.
- Point and Linear Features, Setup, and Observation data are stored in the DGN.

Please Note: Setups, Observations, and Control Points will be drawn to specific levels in the DGN file.

- Linking Codes are processed to create line work (Linear Features).
- Points and Linear Features are symbolized according to the Feature Definitions.
- A surface named ”AllFieldbooks” is produced using the points and lines from the raw data.

Survey uses three (3) types of Linear Features: Dynamic Link, Point List, and Graphic. These linear feature types are hierarchical. A Dynamic Link type can be converted to a Point List or a Graphic type. A Point List type can be converted to a Graphic type.

Linear Features, automatically generated through the use of one of the Linking Methods (Field Code, Consecutive, or Non-Consecutive), are created as Dynamic Link linear features and have a property type of GeneratedByLinkCodes. These linear features are constructed based on the combination of linking and/or field codes and the order in which field points are collected. If a linear feature is started, it will link all subsequent points with same field code until it encounters another start or an end depending on the Linking Method used.

- Dynamic Link: Creation is described above. All points within these linear features are of the same field code and the linking of these points is in the order they were collected in the field. Starting, stopping, and changing of geometry of these linear features is controlled by a
combination of linking and/or field codes. Editing consists of modifying linking and/or field codes or moving the location of the survey point features.

- **Point List**: These linear features are generated by a list of points that can be of any field code. These have a property type of GeneratedByPointList. The order of the points in the linear feature is not dependent on the order they were collected in the field but is solely dependent on the order they appear in the list. The Geometry of this type is still controlled by the link codes but not where the linear feature starts and ends. This is controlled by the point list. Editing consists of modifying linking and/or field codes or moving the location of the survey point features in addition to modifying or managing the order of the points in the list.

- **Graphic**: A graphic linear feature can be any MicroStation graphical element and is not tied to any survey point features. These have a property type of Graphic. Editing consists of using any MicroStation edit tool. The symbolization of these linear features can be controlled by the assigned feature, but assigning a specific feature is an option – not a requirement.
Terrain Model triangles created from the REC files – The Terrain Model is generated automatically based on the Terrain Model settings of the imported point features and linear features.
2.3 Creating Terrain Model

A Terrain Model is automatically created when raw survey data is imported into the Field Book. Any changes to survey will automatically change the survey Terrain Model.

2.3.1 Create Terrain Model from a Field Book

To manually create a Terrain Model of the survey, right-click on the Field Book of interest in the Survey tab, select Create Terrain Model.

Note: To change the name of an existing Terrain Model, right-click the Terrain Model in the Civil Model tab of the Project Explorer and select Properties. Change the Name of the Terrain Model in the Element Information dialog.

2.3.2 Create Terrain Model Based on Field Book Selection Set

The Create Terrain Model from Field Book Selection Set command builds a separate Terrain Model from a selection set of Field Book data.

To create a terrain model from a field book selection set:

1. Create a Selection Set of the desired point and linear feature elements in the DGN Model.
2. In the Survey tab, right-click on the Field Books item.
3. Select Create Terrain Model from Field Book Selection Set from the menu.

Note: To change the name of an existing Terrain Model, right-click the Terrain Model in the Civil Model tab of the Project Explorer and select Properties. Change the Name of the Terrain Model in the Element Information dialog.
2.3.3 Export Terrain Models

Terrain Models can be exported to one of four formats, allowing design processes to continue in native design applications.

To export a Terrain Model, right-click on the Terrain Model in the Civil Model tab and select Export Terrain Model followed by one of the following options:

- **GEOPAK TIN** – creates a TIN file, which is the standard GEOPAK terrain model format
- **InRoads DTM** – creates a DTM file, which is the standard InRoads terrain model format
- **LandXML** – creates a Terrain Model in a LandXML file
- **MX** – creates a Terrain Model in a MX model file
2.4 Exporting to Geometry

When you have finished processing data, you may wish to export the point and linear features to a coordinate geometry database and continue the design process with the native product's design tools.

To export the survey lines and points, right-click on the Field Book in the Survey tab and select Export and one of the following options:

- **GEOPAK Format** – creates a GPK file, which is the standard GEOPAK Coordinate Geometry format
- **InRoads Format** – creates a ALG file, which is the standard InRoads Geometry Project format
- **LandXML** – creates a LandXML file of the geometry
- **MX** – creates a MX FIL file, which is the standard MX geometry format
2.5 Exporting to DGN Graphics

A new MicroStation Design file can be created that includes all the graphics of the current survey project, but with no survey logic attached to it. This command strips all the intelligence that is attached to the graphics, resulting in plain MicroStation graphics.

To access this command, right-click on a Field Book and select Export To > DGN Graphics.
2.6 Project Explorer - Survey Tab

![Project Explorer screenshot]

2.6.1 Default Branch

**Default** – At the top of the tree is the name of the active DGN model. All data imported is stored in this model.

2.6.2 Survey Data (Field Books) Branches in the Data Tree

When populated with data, the Data Tree contains one or more branches. Each branch is accompanied by a checkbox that enables/disables the visualization of the branch and sub-branches.

- **Field Books** – Expands to show all of the field survey data loaded into the project. To create a new Field Book, right-click on the Field Books branch and select **New**.
- **Field Book** – Created as a subfolder under Field Books. To create a new survey, right-click on the Field Books and select **New**. To import a raw survey data file, right-click on the Field Book and select **Load > File**.
- **Data Files** – Expands to show all of the raw survey data files currently loaded into the Field Book. Each Data File expands to show setups and observations.
- **ALL Point Features** – Lists points loaded from the survey raw data files. The Point Features branch expands to show a list of individual feature names.
- **ALL Linear Features** – lists linear features loaded from survey raw data files – The Linear Features branch expands to show a list of individual feature names.
- **ALL Control Points** – Lists the control points that exist in the Field Book.
- **ALL Setups** – Lists the setup points that exist in the Field Book.
- **ALL Observations** – shows all observations loaded from the survey raw data files.

- **Adjustment** – When activated, a *Least Squares Adjustment* is applied to the Field Book. To activate the adjustment, right-click on Adjustment and select **Turn On**. The circular symbol to the right of the Adjustment branch will become green when the adjustment option has been enabled. The check box toggles the graphical display of the error ellipses resulting from the adjustment.
**Point and Linear Features Expansion**

By expanding the *All Point Features* or *All Linear Features* branch, you can view data by individual feature definition. The Point Features branch displays different feature types that have been assigned to points in the Field Book. When you select one of these sub-branches, the *Details Panel* presents only points that have been assigned to the selected feature definition. The *Linear Features* branch can be similarly expanded and operates in much the same way.

### 2.6.3 Filters Branch

The Filters branch allows you to create customized Filters for quick viewing of data sub-sets. These Filters can be pre-created and stored in the Survey workspace for use with all projects. An example Filter may only show points whose elevation is above or below the expected range within a geographic area.

![Filters example](image1)

Another example may be to show all “default” coded points to provide visual feedback of field coded points that did not match the available feature definitions.

![Filters example](image2)

**Filter Creation**

To create a new Filter, right-click on the *Filters* branch item in the data tree and click **New**.
The Create New Filters dialog will open.

- **Name**: Supply a name for the filter.
- **Category**: A category that will be used in the branch above the Filter Name.
- **Description**: A brief description of the Filter.
- **Use Fence**: True/False toggle. Once the Filter has been created, you can right click on the Filter and choose Show Details. If the Use Fence Option is set to True and a MicroStation Fence is active, then only the items that match the Filter AND are within the MicroStation Fence will be shown in the Survey Details panel.
- **Filter Value**: Setting the Filter Value is the most important part of the Filter. The Filter Value is what allows the user to choose the parameters for the items they wish the Filter to include (or exclude).

The values defined by the Filter are very similar to a search on a database of records such as a phone book. The primary difference is that this search is performed on a Survey database.

Click the **Browse** button in the **Filter Value** field to launch the **Filter** dialog shown below.

**Filter Dialog**: Multiple rows can be added to a single filter using combinations of Object Type, Property Name, Operator, and Values to build the required filter using the New button. Once the filter rows are completed, click the Accept button. The filter will appear in the Data Tree under “Filter <category> <name>”.

Please note that between each row is an inferred “and” condition. For data to pass a filter, it must fulfill the attributes of filter line 1 AND the attributes of each subsequent filter line.
Filter Activation

To activate one or more filters:

1. Disable the display of the data type you are filtering (point features and/or linear features) within the Field Book area of the Data Tree.

2. Drill down the Filters branch to the specific filter/filters you wish to activate.

3. Enable the desired filters.

The data passing the enabled filters will display on your screen.

To display the results of the filter in the Survey Details panel, right-click on the filter and select **Show Details**. This will populate the Details panel with the data that has passed the filter.
2.6.4 Edit Feature Tools

The Survey Edit Features tasks can be accessed from the Survey Processing tasks group.

They can also be accessed by selecting survey features and selecting the Edit Feature commands from the heads-up menus.

- **Append Point In Linear Feature** - Adds an existing point feature to the end of a linear feature. This tool will connect the linear feature to the point feature and change the Feature Definition of the point feature to match the linear feature.

- **Insert Point In Linear Feature** - Inserts an existing point feature into a linear feature. This will insert the point feature into the linear feature and change the Feature Definition of the point feature to match the linear feature.

- **Remove Point From Linear Feature** - Deletes an existing point feature from a linear feature.

- **Move Point Along Linear Feature** - Moves an existing point feature along a linear feature. You have to option to hold the elevation of the point being moved.

- **Transpose Linear Feature** - Reverses the direction of the way the points were captured in a linear feature. This tool is frequently used to for the purpose of changing the direction of custom line style produced by survey linear features.

- **Break Linear Feature** - Breaks one linear feature into two distinct linear features. The break will occur at a selected linear point feature.

- **Close Linear Feature** - Closes a linear feature. There is an option whether to Close Shape or not. If the Close Shape option is set to True, the linear feature is closed such that the angles of the last
segments are at 90 degrees to the linear feature. If the Close Shape option is set to False, then the linear feature will be closed by using a straight line between the two end points of the linear feature.

**Join Linear Features** - Joins two linear features to form one linear feature. This command can only be used on linear features that are Point List Linear Features.

**Move Linear Feature** - Moves a linear feature to a new location. The point features of the moved linear feature maintain their original elevations.

The following two tools are only accessible through the heads-up menu.

**Convert to Point List Linear Feature** - Converts a Dynamic Link Linear Feature to a Point List Linear Feature. The Join Linear Feature tool can only be used on Point List Linear Features. Using the Convert to Point List Linear Feature tool also provides additional options when using the Manage Point List tool.

**Manage Point List** - Used to perform operations on linear features that are generated by Point Lists. Point list Linear Features are comprised of a list of points and the order of the points indicate the linear feature geometry. Linking codes also dictate the shape of the linear feature. The manage point list dialog allows the user to add, remove, replace or reorder points in a point list linear feature. In addition, the linking code of any point in the in the linear feature can be changed using this dialog.

**Edit Point Features** - Lists the point features that were used to construct the linear feature in question. This tool displays the points that were used to construct the linear feature in the Survey Details pane.
2.6.5 Report Crossing Features Tool

The Report Crossing Features tool can be accessed from the Terrain Model tasks group. This tool locates intersecting line features, such as break lines or contours. At the intersection, the elevations of the two elements is computed and compared. If the elevation difference at the intersection of the two elements is less than the specified tolerance, they are not listed in the report.

![Image of Terrain Crossing Features Report](image)

You will be prompted whether to use a Level Tolerance or not. The Level Tolerance acts as a filter for the report. If the intersection of the two crossing features has an elevation difference less than the Level Tolerance, they are not included in the report. An example report is shown below.

Right-clicking on any row in the Terrain Crossing Features Report will display View and Edit tools for the user to resolve elevation differences in Linear Features that are part of the selected Terrain Model.

![View and Edit tools](image)
2.7 Group Exercise #1 – Importing the first REC file:

In this group exercise we will walk through the steps of processing a I502TO13.rec survey file and adding/merging that information to the project’s LiDAR data that was previously generated by an aerial consultant.
Creating the Survey dgn file

1. Within MicroStation select File ➔ New

2. Select No Wizard if you get the following dialog box.

3. Select the “Seed” button to define the seed file.
4. When defining the seed file navigate out to the following location:

**MoDOT Electronic Plans ➔ CADD Standards ➔ Seed Files ➔ Design English**

Select the `i_project_3d_PowerGEOPAK.dgn` as the seed file and then select **Open**.

5. Select **Yes** to opening the file as **Read Only**
6. Type in the name of the new file as **J5P3181_Survey.dgn**

7. Verify the folder were the file is to be stored is in the **Miller ➔ J5P3181 ➔ data** folder.

8. Select “**OK**” to create the file.

   Note: Typically in SS4 Survey files are 3D.
Setting the Geographic Coordinate System

9. In the MicroStation Tools select the **Geographic Coordinate System** tool.

10. In the **Geographic Coordinate System** tool dialog select “From Library” icon.

11. Set the following Geographic Coordinate System from the **Modified Geographic Coordinate Systems (NAD 83/2011):**

   CD - Miller 2011 - NAD83/2011 Missouri State Planes, Central Zone, US Foot

12. Close the **Geographic Coordinate System** dialog
Creating a new Field Book

13. Select the **Survey** tab from the **Project Explorer**.

- If you do not have a Project Explorer Tab select **Files ➔ Project Explorer**
- Note you can “Pin” the Project Explorer Dialog so that it does not collapse by selecting the “Pin” in the upper right corner.

14. Right-click on **Field Books** and select **New**.

15. Rename **Field Book 1** by right clicking on the field book and selecting Properties. In the properties dialog change the name to **J5P3181**.

Note: Typically, there is only one Field Book per Project
Importing Survey Data (MoDOT Rec file)

16. From the Survey tab in Project Explorer, right-click on the J5P3181 Field Book and select Load ➔ File.

17. In the ProjectWise “File Open” dialog Set the Application: to All Applications.
SS4 Power GeoPak Survey

18. Select the I502TO13.REC file from the folder

   pw:\District CADD\Survey\MILLER\J5P3181\data\ and click Open.

19. Review the survey data visualized in the J5P3181_Survey.dgn.

   All points can have up to four Annotations

1) **Point Name** = 3045

2) **Elevation** = 749.9458

3) **Survey Feature** = 318

4) **Description** = REINF. CONC. PIPE
Changing the Annotation Scale

Annotation Distance from the Survey point is based on the Drawing Scale. If the Drawing Scale is modified the distance of the annotation to the Survey Point will not change until a “Redraw” is performed.

20. Change the Drawing (Annotation) Scale to 1”=10’ by selecting Settings > Drawing Scale.

Note: When the Drawing Scale is changed, the text size is adjusted but the placement location remains the same. To adjust the placement location of the text the User will need select the Survey Processing Tool Redraw after changing scales to see the placement location of the survey text update to the correct location from the survey point origin.


Note: Selecting Shift F1 is also a shortcut to the Redraw function.
Turning off the Annotation

There are two ways to turn off Survey Annotation. If the User needs to turn off all or certain individual annotation labels, use the Project Explorer ➔ Survey Tab. To turn off all annotation in one step use the Task ➔ Civil Tools ➔ Survey ➔ Survey Processing ➔ Survey Miscellaneous tools ➔ Turn On/Off All Annotation.

22. In the Project Explorer ➔ Survey tab, right-click on the All Point Features and select Annotations ➔ Turn off Features, Elevations, and Descriptions.

Note: You can also turn off and On all annotation by using Task ➔ Civil Tools ➔ Survey ➔ Survey Processing ➔ Survey Miscellaneous tools ➔ Turn On/Off All Annotation.

Note: Turning off annotation by the Level Display is not recommended and has cause issues with both Design and Survey Staff.
Comparing the Survey with the Project’s LiDAR Data and Bing Maps

23. Within the **Reference** dialog, attach the **J5P3181_LiDAR_Graphics.dgn** file.

   Once attached compare how the survey data lines up with LiDAR graphics.

24. Within the **Raster Manager** dialog, select **Attach ➔ Bing Maps**.

![Image of Raster Manager dialog showing the option to attach Bing Maps](image1)

When attaching a Bing Map you can specify what type of layers to display. Select **Road** layer.

![Image of Raster Attachment Options dialog](image2)

25. Once attached compare how survey data lines up with Bing Maps. **When finished detach the Bing Map.**
Reviewing the Survey Details Pane

26. Open the Survey Details Pane by selecting the following: Task ➔ Civil Tools ➔ Survey ➔ Survey Processing ➔ Show Details

27. From the Survey tab, expand the J5P3181 branch and select All Point Features and then select All Linear Features.

The User will notice the Survey Details panel will list all the Point and Linear Features.

Point Features

Linear Features
Auto Center on and fix Feature Code for Point 2186

28. Using the Details Pane, select the far left column of point number 2186.

Note: When you click on the row for point number 2186 it should Auto Center the point in the middle of the screen and Auto Highlight. If it does not right click in the far left column of point 374 and select the following:

View ➔ Turn On Auto Center
View ➔ Turn On Auto Highlight

29. Adjust the Feature Definition of Point 2186 from D20 to 720

Before Change

![Before Change Image]

After Change

![After Change Image]
Connecting Linear Features

30. In the Survey Details panel, locate point named 3404 and select the row. Once the row is highlighted the point should be Highlighted and Centered in the screen.

To join the two Linear Features indicated with red arrows, we first must change point 3404’s Link Code from “End” to “None”
31. Left click on the Linear Feature 722_7 (the ending point is 3404). From the heads-up menus, select Append Point In Linear Feature.

32. When GeoPak prompts the User to locate the Point Feature select the Point Feature 3406.

Lastly, accept the appending of the two Survey Linear Features with a Left Click.
**Transposing Linear Features**

33. To reverse the direction of the Flow Line, select the **Transpose Linear Feature** icon from the Survey Processing tasks group or from the heads-up tools when selecting the Survey Linear Feature.

34. Left Click on each Flow-line in the area below and in the heads-up tools select **Transpose Linear Feature**.

35. Select **File ➔ Update Server Copy**.
Create Terrain Model for the North section of the I502TO13.rec Data File

36. Select the north section’s Survey attributes by placing a selection fence around the data.

37. In Project Explorer Survey Tab right click on Field Books and select Create Terrain Model From Field Book Selection Set
38. Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select **Properties**. Then turn “ON” and “OFF” and adjust the various settings.

a. Change the Feature Name to **I502TO13.rec North**
b. Change the Feature Definition to **Existing Triangles**. It is helpful to see the triangle legs when setting the Max Triangle length in the next step.
c. Change the Edge Method Length using various lengths to determine the best distance for the data. This manual will use **105 feet** for the Max Triangle Length.

![Feature Name and Definition](image)

- Lastly, change the Feature Definition back to **Existing Boundary**

39. Select **File ➤ Update Server Copy**.
Create Terrain Model for the South section of the I502TO13.rec Data File

40. Select the south section’s Survey attributes by placing a selection fence around the data.

41. In Project Explorer Survey Tab right click on Field Books and select Create Terrain Model From Field Book Selection Set.
42. Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select **Properties**. Then turn “ON” and “OFF” and adjust the various settings.

d. Change the Feature Name to **I502TO13.rec South**

e. Change the Feature Definition to **Existing Triangles**. It is helpful to see the triangle legs when setting the Max Triangle length in the next step.

f. Change the Edge Method Length using various lengths to determine the best distance for the data. This manual will use **80 feet** for the Max Triangle Length.

- Lastly, change the Feature Definition back to **Existing Boundary**

43. Select **File ➔ Update Server Copy**.
Resolving Linear Crossings

44. To report and resolve linear crossings, select the Report Crossing Features icon from the Terrain Model tasks group.

45. Select the Terrain Model named I502TO13 North when prompted to Select Terrain Model element.

46. When prompted to Apply Elevation Tolerance, set the option to Yes and click to accept.

47. Key in 0.5 for the Elevation Tolerance and click to accept.


49. Right-click on the first crossing in the Terrain Crossing Features Report dialog and select Zoom To.

50. Move or adjust coordinates of point that is causing the overlap.

   Note: When moving a point dynamically, be careful not to adjust its elevation to zero. To avoid this, select leg of point and then left-click and hold while moving point.

51. Close the Terrain Crossing Feature Report dialog.

52. To view surface in more realistic view of the surface switch the Feature Definition to Existing Triangles and then go to View Attributes and change the Display Style to Smooth with Shadows and rotate the view looking for spikes in the surface.

53. Switch the View Attribute Display Style back to Wireframe.
Editing the Terrain Model

54. Next we are going to edit the terrain model and remove all false triangles legs.

In order to edit the Terrain Model, the User will need to “Deactivate the Surveying Processing Rules”

55. In Project Explorer ➔ Survey Tab, right click on Default and select Deactivate the Surveying Processing Rules.

56. In order to edit the terrain model it is best see the triangles of the Terrain Model.

If you have not already done this Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select Properties. Then change the Feature Definition to Existing Triangles.

Note: If the User would have left the Feature Definition as Existing Boundary and just changed the Triangles display option to the “On” position, the Triangle display option would have reverted back to “OFF” position after an edit to the triangles. After an edit occurs the default Feature Definition display setting are applied, and with the Existing Boundary Feature Definition the default Triangle display setting is set to “OFF”.

57. To edit the Terrain Model, select the **Edit Terrain Model** tool located under **Task ➔ Civil Tools ➔ Survey ➔ Terrain Modeling ➔ Terrain Model Edit**

![Terrain Model Edit - Task](image)

58. One of the easiest ways to delete edge triangles is using the **Delete Triangle By Line** tool.

![Edit Terrain Model](image)

59. First select the terrain model to edit by left clicking on the terrain. Next left click and hold at the same time dragging your mouse, placing a line over the triangles to be deleted.

![Terrain Model](image)

**Note:** If you make a mistake deleting a triangle, simple select **Edit ➔ Undo** or select **Control Z**

60. Once the triangles are all cleaned up, left click on the Boundary edge of the Terrain Model and from the heads-up tools select **Properties**. Change the Feature Definition back to **Existing Boundary**.
Creating the Terrain Model dgn file.

To help preserve the Surveyor’s terrain edits, we will export all of the terrain model(s) into a single dgn file used to store all the terrain models for the project.

61. Create a new 3D file called J5P3181_Terrain.dgn (see Step 1 for detailed instructions)

62. Set the Geographic Coordinate System to the following:

   Modified Geographic Coordinate Systems (NAD 83\2011):

   CD - Miller 2011 - NAD83/2011 Missouri State Planes, Central Zone, US Foot

63. Attach the J5P3181_Survey.dgn.

64. Utilizing the Level Display and the Used filter, turn off all level except for level names starting with the word “Modeling” in the referenced J5P3181_Survey.dgn file.

Leaving these levels on:

- Default
- Modeling-Boundary-Existing
- Modeling-Breakline-Existing
- Modeling-Contours-Major-Existing
- Modeling-Contours-Minor-Existing
- Modeling-Flow Arrows-Existing
- Modeling-High Points-Existing
- Modeling-Hole-Existing
- Modeling-Island-Existing
- Modeling-Low Points-Existing
- Modeling-Spot-Existing
- Modeling-Terrain-Existing
- Modeling-Triangle Vertices-Existing
- Modeling-Triangles-Existing
- Modeling-Void-Existing
- Survey-Ditches
- Survey-Drainage structures concrete
- Survey-Drainage structures-metal
- Survey-Edge of pavement
- Survey-Entries
- Survey-Flow line
- Survey-Misc paved surface

Leave these levels on.
65. Open the **Reference** dialog and **Merge into Master** the `J5P3181_Survey.dgn`.

![Reference dialog](image)

*Note: If any Survey data is visible while **Merging into Master** the Survey Field Book will also get merged. Typically you do not want any Field Book information in the Terrain file.*

66. When elements are merged into another file, the elements lose their feature definition setting. To reestablish the Feature Definition on the terrain models use the **Set Feature Definition** tool by selecting the following:

```
Task ➔ Civil Tools ➔ Survey ➔ General Geometry ➔ Set Feature Definition
```

Fill out the dialogs for the two Terrain Models, and then locate the terrain (Left click) and Reset to complete (Right click).
Merge Survey Terrains with LiDAR Terrain.

67. Attach the J5P3181_LiDAR_Terrain.dgn & J5P3181_Survey.dgn files.

68. Next we will merge the three terrain models together using the following tool:

   Task ➔ Civil Tools ➔ Survey ➔ Terrain Model ➔ Create Complex Terrain Model

69. Define the Complex Terrain Model dialog as follows and select Finish:

   Feature Definition: Existing Triangles
   Name: J5P3181 Existing Ground

Notes:

a) The merge terrain will replace the information in the primary terrain where they overlap.
b) The Complex Terrain Model tool will create a new Terrain Model.
c) If you use the append option, the Complex Terrain Model tool will add the terrain information together in areas of overlap.
Removing Rules from J5P3181 Existing Ground Terrain Model

Because we created the **J5P3181 Existing Ground** Terrain model using the **Create Complex Terrain Model** tool, the program created rules back to the original three terrain models. Meaning if any of the original terrain models would be detached or deleted, that area of the final terrain model would also be removed. In other words, the terrain model created by the merging of the original terrain models is still linked to the original terrain models.

To stop this functionality the User would need to drop or break the rules back to the original terrain model(s). If the User does not break the rules back to the original terrain models and if they would ever be detached the files containing the terrain models the following dialog would appear.

![Delete Reference Dialog](image)

70. Select the edge of the **J5P3181 Existing Ground** terrain model and select the **Remove Rule** tool from the heads up tools.

71. Once the rules are removed, the referenced LiDAR terrain model can be detached from the dgn.

72. The two original terrain models from the I502TO13.rec file can also be deleted.
Creating the Survey Graphics dgn

To help the Design Staff out with a known bug in the Design side of the Power GeoPak software with targeting Horizontal Feature Constraints the Surveyor will need to create a separate file that has all Survey Graphics within it.

73. Open the J5P3181_Survey.dgn file.

74. Delete the North and South Terrain Models.

75. Turn off all Survey Annotation.

76. Using the Level Display turn off any level you do not want to see in the exported file. Select Save Settings.

   Note: Items turned off by level display will still be part of the exported file.

77. If not already displayed, turn on the display of the referenced LiDAR_Graphics.dgn file.

78. Select File ➔ Update Server Copy

79. Within Project Explorer ➔ Survey Tab select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Export To ➔ DGN Graphics
80. The export tool will take the User outside of ProjectWise. Save the file to the Desktop and name the file Exported_Graphics.dgn

**Note:** the file will take on all the attributes of the J5P3181_Survey.dgn file, including the set Geographic Coordinate System.

81. When prompted by ProjectWise, **Check In** the file J5P3181_Survey.dgn

82. Review the Exported_Graphics.dgn file. It is a 3D file with no Survey attributes in the file, just MicroStation elements.

**Note:** You will notice the LiDAR Graphics came across as well; this is because those elements were visible when the export was initiated. Any referenced items visible during the export process will be also be visible and still referenced after the export process.

83. In the Reference Dialog select the LiDAR_Graphics file and select **Merge into Master**. Once merged close the Reference Dialog.

84. Open the J5P3181_Survey.dgn file.


87. At this point Surveyor should send the Designer the following two files:

- J5P3181_Graphics.dgn
- J5P3181_Terrain.dgn
Exporting Survey Features to a LandXML file - Survey Linear Feature

88. In Project Explorer ➔ Survey tab, expand Default, Field Books, J5P3181, and select All Linear Features.

89. In the Survey Details Pane, select the row that has Survey Linear Feature named 121_16.

90. Right Click in the first Column and select Export selected items ➔ LandXML Format and save the file with the following name: J5P3181_Survey_Linear_Feature.XML
91. Within ProjectWise and using Notepad open the newly created LandXML.
Exporting a Terrain to a LandXML file – Terrain Model

92. Open the **J5P3181_Terrain.dgn** file.

93. Select the any part Terrain Model and from the head-up Tools choose the following

   Export Terrain Model ➔ LandXML

Fill out the dialog with the values below and save the file with the following name:

**J5P3181_Terrain_Model.XML**
94. Within ProjectWise and using Notepad open the newly created LandXML.
Exporting a Geometry to a GPK file

95. Open the J5P3181_Survey.dgn file.

96. Open the old GeoPak Coordinate Geometry tool, also known as “COGO”

97. Create a GPK file (if one does not already exist).
98. Within **Project Explorer ➔ Survey Tab** select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Export To ➔ GeoPak Format

**Notes:**

a) Exporting a large Survey to a GPK can take some time.

b) When you export geometry this way to a GPK, all Point and Linear Features are exported and will overwrite any existing data in the GPK.
Exporting individual Geometry to a GPK file - Optional

A second way to export Geometry to a GPK is the following:

In Project Explorer ➔ Survey tab, expand the following folders Default, Field Books, J5P3181. Then select either: **ALL Point Features** or **All Linear Features**.

In the Survey Details Pane, select the row(s) that are to be exported to the gpk.

Right Click in the first Column and select **Export selected items ➔ GEOPAK Format**

**Note:** with this method the User chooses what Feature(s) are to be exported to the GPK.
2.8 **Group Exercise #2 – Importing additional REC files:**

1. Open the **J5P3181_Survey.dgn** file.

2. Within **Project Explorer ➔ Survey Tab** select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Load ➔ File
3. Select the **1508TO17.rec** file to process.
Extending a Linear Feature by Adding Point

The User needs to close the gap between point number 4261 and 4258 by adding (appending) point 4258 to Survey Linear Feature 207_7 from Data File I508TO17.rec

4. Within Project Explorer ➔ Survey Tab select the following:
   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ ALL Point Features

5. In the Survey Details Pane, select the column header “Name” and right click and select Find.
6. In the find box type in **Point Name 4261** and select **Find Next**.

![Find and Replace dialog box](image1)

**Note:** Because **Locator** and **Auto Center** are turn on by default, once point feature **4261** is selected, it should be centered in the middle of the window.

![Survey Details window](image2)

7. From the **Survey Linear Feature 207_7** (Bituminous Edge of Pavement), using the heads-up (manipulate) tools use the **Append Point in Linear Feature** tool to add the point.

![Append Point in Linear Feature](image3)
Adding information to a Point Feature

8. Within Project Explorer ➔ Survey Tab select the following:
   
   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ ALL Point Features

9. In the Survey Details Pane, select the column header “Name” and right click and select Find.

10. In the find box type in Point Name 4688 and select Find Next.
11. In the Details Pane, within the row for **Point Name 4688**, left click in the first column to highlight the entire row and center the point in the middle of the Drawing Window.

Modify the Feature Definition from **150** (Spot Elev. On Dirt) to **73** (Land Corner Marker)

12. Add a media file by clicking in the **Media File** field/column and add a file called: **Survey Marker.jpg**
13. To view the media file select the edge of the point symbol for point feature 4688 and in the heads-up tools select Media.

Note: Be careful not to move the Point when trying to access the “Point’s” heads-up tools.
Create the Terrain Models for the I508TO17.rec

14. Because the I502to17.rec survey data straddles the survey information from the I502TO13.rec, we will need to create two terrain models, one from the western and then one from eastern side of the I502TO19.rec survey data. When creating these terrain models, we want to include the area in between the I502TO13.rec data and the I502TO19.rec data. If we didn’t do this, we would have a void area in-between the two surfaces.

To do this we need to break the western-most 207 Linear Feature (Survey-Edge of Pavement) at the point location 3081 selecting the following heads-up tool:

15. Next select the Edge of Pavement linear Feature and from the heads up tools select Break linear Feature and then when it asks to Locate Point Feature select Point 3081.
16. Next break the eastern-most 207 Linear Feature (Survey-Edge of Pavement) at the point location 2010 using the following heads-up tool:

![Break Linear Feature]

17. Next we need to select the Edge of Pavement linear Feature and from the heads up tools select **Break linear Feature** and then when it asks to Locate Point Feature select **Point 2010**.
18. To create a terrain model for western side of the roadway use the Element Selection method of Shape along with the mode of Add, select the I502to17.rec survey data. Next, using the Element Selection method of Individual along with the mode of Add, select the newly broken western Survey-Edge of Pavement Linear Feature from the I502to13.rec survey data.
19. In Project Explorer Survey Tab right click on Field Books and select Create Terrain Model From Field Book Selection Set

20. Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select Properties.
   - Turn on triangles to view how vertices were created along the newly broken Survey-Edge of Pavement Linear Feature from the 1502to13.rec survey data. The reason there are so many vertices is due to the default linear stoking setting in the system configuration.

21. Next in the Terrain Model Properties define the following:
   - Change the Feature Name to 1502TO17 West
   - Change the Edge Method Length to 60 feet
   - Change the Feature Definition to Existing Boundary
22. To create a terrain model for eastern side of the roadway use the Element Selection method of **Shape** along with the mode of **Add** and select the **I502to17.rec** survey data. Next, using the Element Selection method of **Individual** along with the mode of **Add** and select the newly broken eastern **Survey-Edge of Pavement Linear Feature** from the **I502to13.rec** survey data.
23. In **Project Explorer Survey Tab** right click on **Field Books** and select **Create Terrain Model From Field Book Selection Set**

![Project Explorer screenshot](image)

24. Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select **Properties**.

- Turn on triangles to view how vertices were created along the newly broken Survey-Edge of Pavement Linear Feature from the **I502to13.rec** survey data. The reason there are so many vertices is due to the default linear stoking setting in the system configuration.

![Default Stoking Tolerance Settings](image)

25. Next in the Terrain Model **Properties define the following**:  
   - Change the Feature Name to **I502TO17 East**  
   - Change the Edge Method Length to **60 feet**  
   - Change the Feature Definition to **Existing Boundary**

![Terrain Model Properties](image)
Resolving Linear Crossings

26. To report and resolve linear crossings, select the Report Crossing Features icon from the Terrain Model tasks group.

27. Select both newly created Terrain Models when prompted to Select Terrain Model element.

28. When prompted to Apply Elevation Tolerance, set the option to Yes and click to accept.

29. Key in 0.5 for the Elevation Tolerance and click to accept.

30. Review the Terrain Crossing Features Report dialog to see there are no Crossing issues.

Editing the Terrain Models

32. Next we are going to edit the terrain model and remove all false trainagles legs. In order to edit the terrain model, it is best see the triangles of the Terrain Models. Left Click on the Boundary edge of both Terrain Models and from the heads-up tools select Properties. Then change the Feature Definition to Existing Triangles.

Note: If the User would have left the Feature Definition as Existing Boundary and just changed the Triangles display option to the “On” position, the Triangle display option would have reverted back to “OFF” position after an edit to the terrain model. After an edit occurs the default Feature Definition display setting are applied, and with the Existing Boundary Feature Definition the default Triangle display setting is set to “OFF”.

33. To edit the Terrain Models select the Edit Terrain Model tool located under Task ➔ Civil Tools ➔ Survey ➔ Terrain Modeling ➔ Terrain Model Edit

34. One of the easiest ways to delete edge triangles is using the Delete Triangle By Line tool.
35. First select each terrain model to edit by left clicking on the terrain model. Next left click and hold at the same time dragging your mouse, placing a line over the triangles to be deleted.

Note: If you make a mistake deleting a triangle, simple select Edit ➔ Undo or select Control Z.

36. Once the triangles are all cleaned up in both Terrain models, left click on the Boundary edge of each Terrain Model and from the heads-up tools select Properties. Change the Feature Definition back to Existing Boundary.
Adding Additional Terrains to the J5P3181_Terrain.dgn

37. Open the J5P3181_Terrain.dgn file.

38. Attach the J5P3181_Survey.dgn file.

39. Next we will merge the two new terrain models with the project terrain using the following tool:

   Task ➔ Civil Tools ➔ Terrain Model ➔ Create Complex Terrain Model

40. Define the Complex Terrain Model dialog as follows and select Finish:

   Feature Definition: Existing Boundary
   Name: J5P3181 Existing Ground 2

Notes:

   a) The merge terrain will replace the information in the primary terrain where they overlap.
   b) The Complex Terrain Model tool will create a new Terrain Model.
   c) If you use the append option, the Complex Terrain Model tool will add the terrain information together in areas of overlap.
Removing Rules from J5P3181 Existing Ground Terrain Model

Because we created the J5P3181 Existing Ground 2 Terrain model using the Create Complex Terrain Model tool, the program created rules back to the original three terrain models in the survey file. Therefore, if the J5P3181_Survey.dgn, with the merging terrain models in it would be detached that area of the final terrain model would also be removed. In other words the terrain model created by the Create Complex Terrain Model tool is still linked to the original terrain models in the referenced files.

To stop this functionality the User would need to drop or break the rules back to the original terrain model(s). If the User does not break the rules back to the original terrain models and if they would ever be detached the reference files containing the terrain models the following dialog would appear.

41. Select the edge of the J5P3181 Existing Ground 2 terrain model and select the Remove Rule tool from the heads up tools.

42. Once the rules are removed, the original terrain model can be deleted from the dgn. Also at this point you can rename the terrain model to J5P3181 Existing Ground.
Exporting I508TO17 Graphics Information

To help the Design Staff out with a known bug in the Design side of the Power GeoPak software with targeting Horizontal Feature Constraints the Surveyor will need to create a separate file that has the Survey Graphics in it.

43. Open the J5P3181_Survey.dgn file.

44. Delete the I502TO17 West and I502TO17 East terrain models.

45. Turn off any Survey Annotation.

46. Using the Level Display turn off any level you do not want to see in the exported file. Select Save Settings.

   Note: Items turned off by level display will still be part of the exported file.

47. Select File ➔ Update Server Copy

48. Within Project Explorer ➔ Survey Tab select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Data Files

   Turn off the display to the I502TO13.rec Data File

49. In the Reference Dialog if attached, detach the LiDAR Graphics file.

50. Within Project Explorer ➔ Survey Tab select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Export To ➔ DGN Graphics
51. The export tool will take the User outside of ProjectWise. First select the Desktop location and then select the existing file name **Exported_Graphics.dgn**

**Note:** the file will take on the attributes of the **J5P3181_Survey.dgn** file

52. When prompted to replace file, select “Yes”

53. When prompted by ProjectWise, **Check In** the file **J5P3181_Survey.dgn**

54. Review the **Exported Graphics.dgn** file. It is a 3D file with no Survey attributes in the file, just MicroStation elements.

55. Using **Windows Explorer** and **ProjectWise Explorer** drag and drop the **Exported_Graphics.dgn** file into the ProjectWise **J5P3181 ➔ Data** folder.

56. In ProjectWise rename the **Exported_Graphics.dgn** to **J5P3181_Graphics_I508TO17.dgn**.

57. At this point Surveyor should send the Designer the following two files:
- **J5P3181_Graphics_I508TO17.dgn** *
- **J5P3181_Terrain.dgn** **

* The Designer should **Merge into Master** the **J5P3181_Graphics_I508TO17.dgn** file into their original **J5P3181_Graphics.dgn** file.

** The Designer should **Replace** their original **J5P3181_Terrain.dgn** with the updated **J5P3181_Terrain.dgn** file.
2.9 **Individual Exercise #3 – Importing additional REC files:**

1. Open the **Survey_Terrain_J5P3181.dgn** file.

2. Within **Project Explorer ➔ Survey Tab** select the following:
   
   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Load ➔ File

3. Select the **I508TO19.rec** file to process.
Create Terrain Model for the I508TO19.rec Data File

4. Because the I502to19.rec survey data is not near any of the other survey information, we won’t have to turn off the previously processed Data Files to create the selection set.

Using the Element Selection tool drag a selection window around the I502TO19.rec survey data.

Note: When making a selection set of the I502TO19 data, don’t worry if you accidentally select some of the LiDAR data. Only information from the Data File will be utilized when making the terrain model.

5. Project Explorer Survey Tab right click on Field Books and select Create Terrain Model From Field Book Selection Set

6. Left Click on the Boundary edge of the Terrain Model and from the heads-up tools select Properties.

   a. Change the Feature Name to I502TO19

   b. Change the Feature Definition to Existing Triangles. It is helpful to see the triangle legs when setting the Max Triangle length in the next step.

   c. Change the Edge Method Length using various lengths to determine the best distance for the data. This manual will use 60 feet for the Max Triangle Length.

   d. Lastly change the Feature Definition back to Existing Boundary
Resolving Linear Feature Issues

7. Zoom into the area around Point Feature 7107

There are three issues that need to resolve with Linear Feature 720_5

**Issue #1** Linear Feature 720_5 goes from 7099 to 7100 then back to 7101 (High point on Pipe).

The linear feature should have been laid out from 7099 to 7101 then to 7100 with a break in the linear feature at 7101

8. Select the Linear Feature 720_5 and from the heads-up tools choose Convert to Point List Feature. This will allow the User to rearrange the order of the points in the Linear Feature.
9. To rearrange the order of points within the Survey Linear Feature select **Manage Point List** from the heads-up tools.

10. Within the **Manage Point List** dialog select the row of point **7100** and then select the Down button to move point **7100** to the end of the Survey linear Feature.

11. Make sure to select the **Accept** button to save the changes.
Resolving Linear Feature Issue - Continued

Issue #2) Rotate the view about point Linear Feature 7107 and you will see that there is an elevation bust between the I502TO19 survey and the LiDAR data.

12. To correct this issue, the User will need to do the following:

   c) Select the cross-hairs of Feature Point 7100 by left clicking on the cross-hairs.

   d) Next the User will need to select the center of the point by left clicking and holding on the center the point.

   e) Lastly, while still holding the left mouse button down, the User will then need to AccuSnap the point to the end of the LiDAR flow line string.

Note: By using the procedure listed above the Survey Point Feature will move to the end of the LiDAR string at the correct Northing, Easting, and Elevation.
Resolving Linear Feature Issue - Continued

**Issue #3** The Survey Flow line Linear Feature 720_5 between point 7101 and 7100 is flowing in the wrong direction. The User will need to break the linear feature at point 7101 and reverse the direction of the flow line between point 7101 and 7100.

13. To correct this issue, the User will need to do the following:
   a) Select Linear Feature 720_5 and bring up its head up tools and select **Break Linear Feature**.

   ![Break Linear Feature](image)

   b) When prompted **Locate Point Feature** select **Point Feature 7101** (Yellow Crosshairs)

14. Next we need to fix the direction of the flow arrows between point features 7101 and 7100.
   a) Select Linear Feature 720_5_1 and bring up its head up tools and select **Transpose Linear Feature**.

   ![Transpose Linear Feature](image)
Resolving Linear Crossings

15. To report and resolve linear crossings, select the Report Crossing Features icon from the Terrain Model tasks group.

16. Select both newly created Terrain Models when prompted to Select Terrain Model element.

17. When prompted to Apply Elevation Tolerance, set the option to Yes and click to accept.

18. Key in 0.5 for the Elevation Tolerance and click to accept.


Modifying the View Attributes - Display Styles

Sometimes it is hard to spot a bust in the terrain model by just looking at the triangles from a terrain model. Sometimes using a different display style and help identify a bust in the survey data.

21. In the Terrain Properties set the Feature Definition to Existing Triangles.

22. In the View Attributes set the Display Style to Smooth with Shadows.

Note: A shortcut to the View Attributes is Control-B
23. Rotate the view using the Dynamic Option in the View Rotation tool. By doing so you should see an elevation bust on a point that causing a spike in the terrain surface.

24. Point 6595 is the point with the busted elevation. Using the chart below fix the elevation as you see fit.

<table>
<thead>
<tr>
<th>Description</th>
<th>Point #</th>
<th>Elevation</th>
<th>Average Elevation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point Before</td>
<td>6592</td>
<td>811.1055</td>
<td></td>
</tr>
<tr>
<td>Busted Point</td>
<td>6595</td>
<td>899.9071</td>
<td>810.07</td>
</tr>
<tr>
<td>Point After</td>
<td>6597</td>
<td>809.0258</td>
<td></td>
</tr>
</tbody>
</table>

25. When finished adjusting the elevation of Point 6595, switch the View Attribute Display Style back to Wireframe.

Note: Another way the User could have easily seen the bust in the surface is by setting the Terrain Feature Definition to Contours.
Adding Additional Terrain to the final Terrain Model dgn

26. Open the J5P3181_Terrain.dgn file and attach the J5P3181_Survey.dgn file.

27. Next we will merge the new terrain model with the project terrain using the following tool:

   Task ➔ Civil Tools ➔ Terrain Model ➔ Create Complex Terrain Model

28. Define the Complex Terrain Model dialog as follows and select Finish:

   Feature Definition: Existing Boundary
   Name: J5P3181 Existing Terrain 2

Notes:

d) The merge terrain will replace the information in the primary terrain where they overlap.

e) The Complex Terrain Model tool will create a new Terrain Model.

f) If you use the append option, the Complex Terrain Model tool will add the terrain information together in areas of overlap.
Removing Rules from J5P3181 Existing Ground Terrain Model

Because we created the J5P3181 Existing Ground 2 Terrain model using the Create Complex Terrain Model tool, the program created rules back to the original three terrain models in the survey file. Therefore, if the J5P3181_Survey.dgn, with the merging terrain models in it would be detached that area of the final terrain model would also be removed. In other words, the terrain model created by the Create Complex Terrain Model tool is still linked to the original terrain models in the referenced files.

To stop this functionality the User would need to drop or break the rules back to the original terrain model(s). If the User does not break the rules back to the original terrain models and if they would ever be detached the reference files containing the terrain models the following dialog would appear.

Select the edge of the J5P3181 Existing Ground 2 terrain model and select the Remove Rule tool from the heads-up tools.

29. Once the rules are removed, the original terrain model can be deleted from the dgn. Also, at this point you can rename the terrain model to J5P3181 Existing Ground.
Exporting I508TO19 Graphics Information

To help the Design Staff out with a known bug in the Design side of the Power GeoPak software with targeting Horizontal Feature Constraints the Surveyor will need to create a separate file that has the Survey Graphics in it.

30. Open the J5P3181_Survey.dgn file.

31. Delete the I502TO19 terrain models.

32. Turn off any Survey Annotation.

33. Select File ➔ Update Server Copy

34. Within Project Explorer ➔ Survey Tab select the following:

35. Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Data Files

   Turn off the display to the I502TO13.rec and I502TO17 Data Files

36. In the Reference Dialog turn off the display to the LiDAR Graphics.

37. Within Project Explorer ➔ Survey Tab select the following:

   Survey Data ➔ Default ➔ Field Books ➔ J5P3181 ➔ Export To ➔ DGN Graphics
38. The export tool will take the User outside of ProjectWise. First select the Desktop location and then select the existing file name Exported_Graphics.dgn

Note: the file will take on the attributes of the J5P3181_Survey.dgn file

39. When prompted to replace file, select “Yes”

40. When prompted by ProjectWise, Check In the file J5P3181_Survey.dgn

41. Review the Exported Graphics.dgn file. It is a 3D file with no Survey attributes in the file, just MicroStation elements.


44. At this point Surveyor should send the Designer the following two files:

   • J5P3181_Graphics_I508TO19.dgn *
   • J5P3181_Terrain.dgn **

* The Designer should Merge into Master the J5P3181_Graphics_I508TO19.dgn file into their original J5P3181_Graphics.dgn file.
** The Designer should Replace their original J5P3181_Terrain.dgn with the updated J5P3181_Terrain.dgn file.
2.10 Appendix: Details Panel - Point & Linear Feature Renaming

Currently, there is no provision to deal with automatic Point Renaming when survey data is imported into Survey. To deal with Point Renaming, you have two options.

Import the first data file into your field book. Select all the points from that data file in the Details panel and append a prefix or suffix. Use Edit Selected > Name (or any property) and use the operators below:

If the property is Numeric (Easting, Angle, Elevation, etc.)

+ - / *
If the property is STRING based you can use:

+ And -

To add a PREFIX or a SUFFIX to a string use:

<PREFIX STRING> +

+ <SUFFIX STRING>
Another example is adjusting the Terrain Model Attribute. Sometimes a Surveyor may want to exclude a Point or Linear Feature from the Terrain Model. A way to do this is with the following:
## 2.11 Appendix: Bentley Point Coding

Below is a clip from the Civil Help file explaining the various linking/control codes:

### Linking Codes:

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>begins creating a Linear Feature</td>
</tr>
<tr>
<td>StartPC</td>
<td>starts a linear feature in Arc Mode</td>
</tr>
<tr>
<td>ArcPC</td>
<td>specifies the beginning of a tangential arc or curve within a Linear Feature</td>
</tr>
<tr>
<td>NonTanPC</td>
<td>specifies the beginning of a non-tangential arc or curve within a Linear Feature</td>
</tr>
<tr>
<td>ArcSingle</td>
<td>creates a three-point arc with previous and next points (does not work at beginning or end of a Linear Feature)</td>
</tr>
<tr>
<td>ArcToArc</td>
<td>ends previous tangent arc and begins another tangent arc (must be preceded by ArcPC)</td>
</tr>
<tr>
<td>NonTanPT</td>
<td>specifies the end of a non-tangential arc or curve within a Linear Feature</td>
</tr>
<tr>
<td>ArcPT</td>
<td>specifies the end of a tangential arc or curve within a Linear Feature</td>
</tr>
<tr>
<td>ArcToggle</td>
<td>toggles between NonTanPC and NonTanPT (depends on pairing)</td>
</tr>
<tr>
<td>End</td>
<td>ends the linear feature (not necessary in most cases)</td>
</tr>
<tr>
<td>CloseShape</td>
<td>closes the ends of the linear feature by adding right angle at both ends and intersecting</td>
</tr>
<tr>
<td>Close</td>
<td>closes the Linear Feature back to the first point</td>
</tr>
</tbody>
</table>
Below is the LinkCodes MoDOT currently has defined:

<table>
<thead>
<tr>
<th>LinkCode</th>
<th>Alpha</th>
<th>Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>None</td>
<td>-1</td>
</tr>
<tr>
<td>Start</td>
<td>BS</td>
<td>-1</td>
</tr>
<tr>
<td>StartPC</td>
<td>SC</td>
<td>-1</td>
</tr>
<tr>
<td>ArcPC</td>
<td>C</td>
<td>-1</td>
</tr>
<tr>
<td>NonTanPC</td>
<td>NTC</td>
<td>-1</td>
</tr>
<tr>
<td>ArcSingle</td>
<td>SAP</td>
<td>-1</td>
</tr>
<tr>
<td>ArcToArc</td>
<td>CC</td>
<td>-1</td>
</tr>
<tr>
<td>NonTanPT</td>
<td>NTT</td>
<td>-1</td>
</tr>
<tr>
<td>ArcPT</td>
<td>EC</td>
<td>-1</td>
</tr>
<tr>
<td>ArcToggle</td>
<td>OC</td>
<td>-1</td>
</tr>
<tr>
<td>End</td>
<td>ES</td>
<td>-1</td>
</tr>
<tr>
<td>CloseShops</td>
<td>CS</td>
<td>-1</td>
</tr>
<tr>
<td>Close</td>
<td>CL</td>
<td>5</td>
</tr>
<tr>
<td>CircleDiameter</td>
<td>CD</td>
<td>-1</td>
</tr>
<tr>
<td>CircleRadius</td>
<td>CR</td>
<td>-1</td>
</tr>
<tr>
<td>RectangleWidth</td>
<td>RECT</td>
<td>-1</td>
</tr>
<tr>
<td>TapeDistance</td>
<td>DIST</td>
<td>-1</td>
</tr>
<tr>
<td>JoinPoint</td>
<td>JPT</td>
<td>-1</td>
</tr>
<tr>
<td>NewTemplate</td>
<td>TMPL</td>
<td>-1</td>
</tr>
<tr>
<td>Elevation</td>
<td>LV</td>
<td>-1</td>
</tr>
<tr>
<td>UpDown</td>
<td>UD</td>
<td>-1</td>
</tr>
<tr>
<td>LeftRight</td>
<td>LR</td>
<td>-1</td>
</tr>
<tr>
<td>FrontBack</td>
<td>FB</td>
<td>-1</td>
</tr>
<tr>
<td>AttributeName</td>
<td>AN</td>
<td>-1</td>
</tr>
<tr>
<td>AttributeValue</td>
<td>AV</td>
<td>-1</td>
</tr>
<tr>
<td>AttributeArray</td>
<td>AA</td>
<td>-1</td>
</tr>
<tr>
<td>Terrain Model Spot</td>
<td>DS</td>
<td>-1</td>
</tr>
<tr>
<td>Terrain Model No Spot</td>
<td>DX</td>
<td>-1</td>
</tr>
<tr>
<td>Terrain Model Break</td>
<td>DB</td>
<td>-1</td>
</tr>
<tr>
<td>Terrain Model No Break</td>
<td>DNC</td>
<td>-1</td>
</tr>
</tbody>
</table>
**Control Codes:**

Control codes must be assigned after the Field code. Control codes can only be Alpha values.

Control and Linking codes can both be used on the same point as long as the Control code is last.

Control codes must be separated from the Field or Linking code with a space.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CircleDiameter</td>
<td>draws a circle of specified diameter around this point (must be within Linear Feature)</td>
</tr>
<tr>
<td>CircleRadius</td>
<td>draws a circle with specified radius around this point (must be within Linear Feature)</td>
</tr>
<tr>
<td>RectangleWidth</td>
<td>draws a rectangle from two points and specified width (must be within Linear Feature)</td>
</tr>
<tr>
<td>TapeDistance</td>
<td>applies field measured distances to the Linear Feature. All measurements are applied 90 degrees from previous segment. Positive values turn right, and negative values turn left. (must be within Linear Feature)</td>
</tr>
<tr>
<td>JoinPoint</td>
<td>joins this point to specified point name (does NOT have to be in linear feature)</td>
</tr>
<tr>
<td>NewTemplate</td>
<td>same as InRoads TMPL Consecutive Start codes will get this linear feature paralleled and translated based off of initial points</td>
</tr>
<tr>
<td>Elevation</td>
<td>sets the Elevation of this point</td>
</tr>
<tr>
<td>UpDown</td>
<td>changes final elevation coordinate of point by value entered</td>
</tr>
<tr>
<td>LeftRight</td>
<td>changes final coordinate of point by adjusting left (-) or right (+) of measured observation by value entered</td>
</tr>
<tr>
<td>FrontBack</td>
<td>Changes final coordinate of point by adding or subtracting a distance from the measured distance</td>
</tr>
<tr>
<td>AttributeName</td>
<td>one method of getting attributes for a point (pairs with Value)</td>
</tr>
<tr>
<td>AttributeValue</td>
<td>One method of getting attributes for a point (pairs with Name)</td>
</tr>
<tr>
<td>AttributeArray</td>
<td>one method of getting attributes for a point (Names and Value in array)</td>
</tr>
<tr>
<td>TerrainSpot</td>
<td>include in DTM as spot</td>
</tr>
<tr>
<td>TerrainNoSpot</td>
<td>do not include in DTM</td>
</tr>
<tr>
<td>TerrainBreak</td>
<td>include in DTM as break</td>
</tr>
<tr>
<td>TerrainNoBreak</td>
<td>do not include in DTM</td>
</tr>
</tbody>
</table>
Bentley Point Coding Examples

Start (ST)

ArcPC (PC)

ArcPT (PT)

ArcToggle (OC*)

NonTanPC (NTC)

NonTanPT (NTT)
StartPC (SC) - Vertical

ESW CD*55

EC CR*32

VBA example

TapeDistance (DIST)

RectangleWidth (RECT)