Chapter 5

Creating Templates

5.1 Create Template Dialog ................................................. 5-1
   5.1.1 Folder Tree Window .............................................. 5-2
   5.1.2 Point Name List .................................................. 5-2
   5.1.3 Components ..................................................... 5-2
   5.1.4 End Conditions .................................................. 5-2
   5.1.5 CADD support templates ..................................... 5-2
   5.1.6 District user templates ....................................... 5-2
   5.1.7 Preview Template Window ................................... 5-2
   5.1.8 Current Template Window ................................. 5-3
5.2 Display Options .......................................................... 5-3
   5.2.1 Center Window .................................................. 5-4
   5.2.2 View Commands .................................................. 5-4
   5.2.3 Testing End Conditions ..................................... 5-4
   5.2.4 Dynamic Settings .............................................. 5-5
   5.2.5 Accessing the Dynamic Settings ......................... 5-5
   5.2.6 Precision Key-In Commands ............................... 5-5
   5.2.7 Creating Templates from Components .................. 5-6
   5.2.8 Dragging and Dropping Components ...................... 5-6
   5.2.9 Pull Down Menus .............................................. 5-7
5.3 Point Constraints .......................................................... 5-7
   5.3.1 Types of Constraints ......................................... 5-7
   5.3.2 Parent-Child Point Relationship .......................... 5-9
   5.3.3 Modifying Constraints ...................................... 5-9
5.4 Template Components .................................................... 5-10
   5.4.1 Simple Component ............................................ 5-10
   5.4.2 Constrained ..................................................... 5-10
   5.4.3 Unconstrained .................................................. 5-10
   5.4.4 Null Point ....................................................... 5-10
   5.4.5 Overlay .......................................................... 5-10
   5.4.6 End Conditions ................................................. 5-11
5.5 Creating Basic Components ............................................. 5-11
   5.5.1 Point Name List and Feature Definition ............... 5-11
   5.5.2 Setting Display Options ................................... 5-11
5.6 The Sign of the Distance and Slope .................................. 5-12
   5.6.1 Adding Components .......................................... 5-12
   5.6.2 Point Properties Dialog .................................... 5-14
   5.6.3 Basic Component Creation Workflow .................... 5-14
5.7 Creating an Overlay/Stripping Component ................................................................. 5-15
5.8 Creation of Basic End Conditions................................................................................. 5-15
  5.8.1 Target Types .............................................................................................................. 5-15
  5.8.2 End Condition Settings ............................................................................................. 5-15
  5.8.3 Testing End Conditions ............................................................................................ 5-16
  5.8.4 Basic End Conditions Creation Workflow .............................................................. 5-16
5.9 Group Exercise 3-1: Creating a Constrained Component - Curb ............................. 5-17
5.10 Group Exercise 3-2: Creating an End Condition ....................................................... 5-20
5.11 Individual Exercise 3-3: Creating an End Condition ................................................. 5-27
5.12 Group Exercise 3-4: Creating a Template ................................................................. 5-29
5.13 Individual Exercise 3-5: Creating a Template ........................................................... 5-37
Chapter 5 – Creating Templates

5.1 Create Template Dialog

The first step to creating a 3D model is to create templates for the roadway design. Templates are dynamic typical sections used in Corridor Modeling that use transverse geometry to create 3D models. Each template contains a series of points and components that represent breaklines, which are used to create the roadway surfaces. All these points, components, and templates are stored in the template library (itl).

CADD Support has created a default template library. This library contains most used components and end conditions at MoDOT. A limited number of templates are available through this template library. The intent is for the user to assemble his/her own templates giving the districts more flexibility in their design; therefore, the default MoDOT library needs to be copied to the user’s working directory using the Start Job routine when creating new projects.

The user accesses all templates available in the standard MoDOT template library. In addition, this is the tool to use to create new components and templates to be used within Roadway Designer.

To access the Create Template Dialog, select the icon through the Corridor Modeler Tools in the Civil Tools Tasks.

The Create Template Dialog is composed of three major areas: Folder Tree Window, Current Template Window, and the Template Preview Window, which are shown below.
5.1.1 Folder Tree Window

This view allows the user to navigate through the template library selected. The folder tree structure begins with the template library. Underneath, the user will find the following categories: Point Name List, Components Folder, End Conditions Folder, CADD Support Templates, and District User Templates. This window is completely user definable, and it has all windows capabilities like right click functions, copy, paste, drag and drop.

5.1.2 Point Name List

This list contains previously created names to be utilized in the creation of new points for creating components for templates. Each point on a template must be unique, so no point can have the same name. CADD Support has created a point name list for standardization.

5.1.3 Components

A component is a set of points defining an open or closed shape that represent different portions of the template. For example, pavement structure, curbs, gutters, shoulders, medians, retaining walls, etc. MoDOT default library has many components from which to choose to create templates. These components are organized in categories according to functionality. These components do not include side slope conditions.

5.1.4 End Conditions

End conditions are simply side slope condition components that tie to existing ground. These include fill slope, cut slopes, ditches and/or combination thereof.

5.1.5 CADD support templates

The MoDOT standard template library will contain a limited number of templates. Only these templates will be housed in this folder.

5.1.6 District user templates

The user will save the template library in his/her working directory and will be able to modify the library by adding new templates or components. Any templates created by a district user should be stored in this folder.

5.1.7 Preview Template Window

The template preview window shows the template that is highlighted in the folder tree view. A Cyan color box denotes the placement location for that template. Usually this is at the origin of the template, but the user can click on any point to move the placement point location. The user can drag and drop from the preview are to the current template window.
5.1.8 Current Template Window

This is the large window on the right hand side of the Create Template Dialog where templates are assembled and edited. The current template window shows the user the name, description and design of the template currently being edited, reviewed or assembled.

![Current Template Window](image)

5.2 Display Options

The two radio buttons allow the user to choose what to display in the center window. The Components option shows the typical section component/template picture. The Constraints option show how each point in the component/template is constrained to each other. Constraints will be covered in another section.

There are two check boxes the user can select for displaying various portions of the template. When the Display Point Names option is checked on, all the point names in the current template are displayed. Point names are long and when displayed the window can be too cluttered. Sometimes templates have hidden components controlled by certain design situations. This concept will be discussed in a later chapter. When the Display All Components option is selected, these hidden components are displayed.
5.2.1 Center Window

The center window is the main graph for creating/modifying templates. This window has its own graphics engine and so it is not a MicroStation window. The scale of the graph is dynamic and changes as you zoom in and out.

The center point of the window is marked by the dynamic origin, which is a magenta-colored box. The dynamic origin is used as a reference point and can be moved to any location in the graph.

5.2.2 View Commands

These commands are similar to the MicroStation view commands. They allow the user to perform the standard zoom in/out, zoom in/out in the X direction, zoom in/out in the Y direction; window in an area, and fit the view, undo, redo, and set dynamic settings.

5.2.3 Testing End Conditions

Test – Opens the Test End Conditions dialog box. This tool allows the user to test the end condition solutions.

This tool displays the current template; the non-solved end conditions and their child components are displayed in dashed lines. The normal components and solved end conditions are displayed as solid lines.
Chapter 5 – Creating Templates

The **Available Targets** area lists all of the targets available whether they are surfaces or specific styles. The user simply selects the desired target, sets the **Surface Slope**, and then clicks on **Draw** to test. The Surface Slope is the slope of the surface that is being placed. The **Reset** button clears all the drawn targets.

**Display Rules** - list the display rules for the current template. Left-click over a value to toggle between True and False. Press the Reset button to restore the original Display Rules values.

**Failure Report** – activates the Results dialog. When a template fails to get a solution on one or both sides, the results show which components failed and which end condition start points were not solved.

**Check Priorities** – tests the template for priority conflicts. Each end conditions starting at the same point has a priority assigned, and must be unique. When a conflict exists, a message is displayed indicating there are end conditions starting at the same point having the same priority assigned. If there are no conflicts, a message box indicating no conflicts is displayed.

**Check Duplicates** – checks for duplicate feature and component names for the given solution. If duplicate feature or component names are found, the Duplicate Feature Name List dialog is displayed. If no duplicates are found, a message to this effect is displayed.

**Close** – dismisses the dialog.

**Help** – displays the help for this dialog.

### 5.2.4 Dynamic Settings

Similarly to the MicroStation AccuDraw tool, the **Dynamic Settings** are used for precision input of the template components and to assign point names and styles when creating components.

It also serves as a compass for the cursor location with respect to the dynamic origin. The dynamic origin can be modified by using the “**Set Dynamic Origin**” at the bottom of the dialog box.

### 5.2.5 Accessing the Dynamic Settings

The Dynamic Settings can be accessed by selecting **Tools>Dynamic Settings** or by using the view control icon . The dynamic setting **Step** should be set to x = 0.1, y = 0.1 before creating templates to allow for easy dynamic positioning.

### 5.2.6 Precision Key-In Commands

- **XY** = Key-in absolute coordinates (x, y)
- **DL** = Key-in delta coordinates from last point placed (defaults to the dynamic origin if it is the first point of a component)
- **HS** = Key-in horizontal delta distance and slope from last point placed
VS = Key-in vertical delta distance and slope from last point placed
OL = Key-in delta coordinates from dynamic origin
OS = Key-in horizontal delta distance and slope from dynamic origin

5.2.7 Creating Templates from Components

Templates can be assembled by dragging and dropping components and end conditions into the Current Template window one at a time.

Each point on a component has a unique point name. These point names are created without being specific to “left” or “right” side of the roadway. The user assigns a prefix or suffix to determine “left” or “right” when creating the template via the Dynamic Settings.

Creating components will be covered in a later chapter.

5.2.8 Dragging and Dropping Components

When two points coincide, a heavy white plus sign will appear. When connecting two components together, the existing connection point name will override the dropped point name. Dynamic Settings should be set before starting to drag and drop components to create a template.

Once a component is created, it can be modified by editing any property, inserting new points, or creating display rules. Once two or more components have been combined, they can also be merged.

To edit components, simply right-click between the components to access the editing commands.
Basic Template Creation Workflow

1. Open Template Library
2. From the folder tree view, right-click and select Create > New Template
3. “Drag and drop” template components
4. Merge Components
5. Verify Point Names
6. Save the Template Library

5.2.9 Pull Down Menus

File – allows the user to create a new template library, new folder, or new template; open another library, save the current library, or import a template from another library.

Edit – has the common Windows commands undo, redo, cut, copy, paste, clear, delete, and rename.

Add – has all the options for developing new components. Components are covered in a later chapter.

The Tools menu offers several tools to manage the template library, but the only two tools pertaining to the MoDOT template library are the Dynamic Settings covered in section 2.6 and the Template Library Organizer, which allows the user to copy components and templates from one library to another.

5.3 Point Constraints

Templates and components are defined by the points making their shapes. Thus point constraints are used to manage the behavior of all template points. The purpose of point constraints is to create relationships between the points in a template so that if one point moves, the other points follow in a predictable manner.

Each template point has a maximum of two constraints on it. A template point with two constraints is considered “fully constrained” and is represented graphically by a red plus sign on the template display. A template point with only one constraint is considered “partially constrained” and is represented graphically by a yellow plus sign. A point with no constraints is considered “unconstrained” and is shown as a green plus sign.

5.3.1 Types of Constraints

There are a total of 11 different types of constraints:

Horizontal - Allows the placement of a new point (or child point) a specified horizontal distance from a reference point (or parent point).

Vertical - Allows the placement of a new point (or child point) a specified vertical distance from a reference point (or parent point).
Slope - Allows the placement of a new point (or child point) using a specified slope from the reference point (or parent point). Slope constraints are absolute. Slopes going from lower-left to upper right are positive regardless of whether the child point is to the left or right of the parent.

**Horizontal Maximum** - The child point has two parent points and remains at the specified horizontal distance from the parent point that is farthest to the right (has a maximum horizontal or X value).

**Horizontal Minimum** - The child point has two parent points and remains at the specified horizontal distance from the parent point that is the farthest to the left.

**Vertical Maximum** - The child point has two parent points and remains at the specified vertical distance from the parent point that is the highest (has a maximum vertical or Y value).

**Vertical Minimum** - The child point has two parent points and remains at the specified vertical distance from the parent point that is lowest (has the minimum vertical or Y value).

**Vector-Offset** - The child point is projected onto the vector defined by two parent points. If the offset is not zero, then the child point will maintain a perpendicular offset from the parent vector at the specified offset value. Negative values indicate an offset to the left of the vector defined by the parent points. Positive values indicate an offset to the right. If the offset is zero, the child point is located on the parent vector.

**Project to Surface (to Existing Ground)** - This constraint must be used in conjunction with one of the previously defined constraints. The other constraint will define the projection direction. The child point will then be projected to the surface with the specified name. If the surface does not exist, or no solution is found, the point will remain where it is placed in the template.

**Project to Design** - This constraint is similar to Project to Surface, except that the point is projected to the design surface of the template. A projection value is given to indicate whether the projection is to be to the left or to the right. Again, the point must also be constrained by one of the previous constraints, excluding the Project to Surface constraint, so that a direction for the projection may be determined. If no solution is found, then the point will remain where it is placed in the template.

**Angle distance** - This command is used to fully constrain a point in the template. This constraint requires two parent points, a distance, and an angle. The point is constrained to the location defined by the distance from the first parent, and the angle from the first parent relative to the vector defined by the two parent points. This constraint creates a rigid-body rotation. When selected, no other constraint types are available.
5.3.2 Parent-Child Point Relationship

When a template point is constrained by either one or two other points, it is considered the “child” of those reference points. The reference points are then known as the “parent” point(s).

If the parent point moves, the child also moves based on the constraints established.

Point B is a child of point A. Point A is unconstrained and shown as a green plus sign on the screen. Point B is fully constrained. Point B has a horizontal and a slope constraint, and is shown as a red plus sign. In addition, the parent point (Point A) has a blue arrow pointing to the child point (Point B).

Visual Indicators for Vertical, Horizontal and Slope Constraints

Child is vertically constrained to parent. When the parent point moves, the child point follows at a constant vertical distance to that point.

Child is horizontally constrained to parent. When the parent point moves, the child point follows at a constant horizontal distance to that point.

Child is constrained to parent by a slope. When the parent point moves, the child point follows a constant slope with respect to the parent point.

5.3.3 Modifying Constraints

Once a point has been created with or without constraints in a template, it can still be modified. Modifications include: adding or deleting constraints, or changing the type of constrained originally set for a point.
5.4 Template Components

Templates are a grouping of several components, and each component is a set of points that defined an open or closed shape. Each component represents a material for the typical section at a particular location. Each component is given a name and assigned a Feature Definition. A Feature Definition is simply the MicroStation symbology used to draw the component both in cross section view as well as plan view.

There are six types of components: Simple, Constrained, Unconstrained, Null Point, Overlay, and End Condition.

Once created, components can be modified as desired. There is no limit to the number of points or components in a template. When templates are paired with horizontal and vertical alignments and superelevation, they define the surface of a corridor. Templates are flexible design components that allow you to model simple highway design items such as ditches and sidewalks to the more complex multi-lane highways with superelevated curves and variable side slopes.

5.4.1 Simple Component

A simple component is a closed parallelogram (4 constrained points) that is defined by the slope and thickness (for example, a pavement layer). In this case, if any point is moved, the entire shape moves keeping the same relationships determined by the original slope and thickness, making this a rigid shape.

5.4.2 Constrained

A constrained component consists of points that are all restricted to the movement of the first point. A constrained point is typically used to manage the behavior of other points in the template. When a point (parent) is moved, any constrained point (child) also moves. This restriction only affects the offset and elevation (x, y) of the restrained point and, the relationship is unidirectional (movement of child point does not move the parent point).

5.4.3 Unconstrained

An unconstrained component is open or closed-shaped with no movement restrictions. This type of component is only used for very specific purposes, such as “tracing” a previously placed component.

5.4.4 Null Point

A null point is a template point that is purposely not related to any particular component. It’s most often used as a reference for controlling other points. A null point is considered a “check or test point”. For example, a null point is used to check if there is an entrance to the right or left of the alignment.

5.4.5 Overlay

This is a special type of component that allows the user to add overlay/stripping properties in order to calculate milling, and/or leveling (overlay) quantities.
5.4.6 End Conditions

An end condition is a special open-shaped component that targets a surface, a surface style, an elevation, or an alignment. In other words, the end condition components are simply the fill/cut/ditch slopes or benching which tie back to ground. The integrity of end conditions can now be routinely tested while the roadway template is being created.

5.5 Creating Basic Components

5.5.1 Point Name List and Feature Definition

Each point used for creating a component must be given a name and a Feature Definition associated with such. CADD Support has created a point name list from which to select. Point naming convention is extremely important in the creation of templates, so especial attention must be paid while creating individual components.

5.5.2 Setting Display Options

The dynamic settings need to be set prior to creating a component, end condition or template.

Key-In

Specifies the type of key in to be performed.

- XY= key in absolute coordinates
- DL= key in delta coordinates from last point placed (defaults to the dynamic origin if it is the first point of a component.
- HS= key in horizontal delta distance and slope from last point placed.
- VS= key in vertical delta distance and slope from last point placed.
- OL= key in delta coordinates from dynamic origin.
- OS= key in horizontal delta distance and slope from dynamic origin.
5.6 The Sign of the Distance and Slope

When defining components with precision input, the sign of the distance is dependent on the parent-child relationship. The parent is always the first point placed when creating template components. The distance is positive if the parent has a lower X or Y value than the child. The distance is negative if the parent has a higher X or Y value than the child. The sign of the component slope is based on the mathematical slope.

5.6.1 Adding Components

Adding components is a simple process guided by dialog boxes, but point name and placement must be carefully thought of before starting the process. The steps are as follow:

1. Create the component structure in the library folder tree to the left.
2. Activate and set and activate the setting display options.
3. Right click on the current template window and select **Add New Component**.
4. Select the type of component desired.
5. Populate the display setting options and current component dialog.

6. Data point to the origin to start placing the component or type 0, 0 using the x, y key-in.

7. Add points by using the precession key-in commands in the dynamic settings to finish the desired shape. For unconstrained and constrained components, once the shape has been drawn, right click and select **Finish** to complete.

Once a component has been created, it can be modified visually by adding, deleting points or taking away/adding constraints. In addition, the entire component can be deleted.

Also, the component can be modified through the point properties dialog box.
Note: In order to modify a component, the user must modify the points making up the component.

5.6.2 Point Properties Dialog

To access the Point Properties dialog box, right click on the point to modify and select Edit Point.

5.6.3 Basic Component Creation Workflow

1. Open a template library
2. Navigate to folder where component will be placed
3. Right click on folder, and select Create Template
4. Select and set dynamic settings
5. Create components by using the point names in the point list
6. Edit any points if necessary
7. Save template library
5.7 Creating an Overlay/Stripping Component

Creating an overlay/stripping component is similar to creating a basic component. The only difference is that overlay/stripping components are a single line “closed” components and they have additional attributes to determine overlay/milling quantities. Detail creation of an overlay/stripping component will be covered in the *Overlay Tools* chapter.

5.8 Creation of Basic End Conditions

End conditions are components of the template used to create cut and fill treatments. These end condition components have a specific target such as, terrain models, elevations, horizontal and vertical alignments.

5.8.1 Target Types

Target types are defined only for end condition components, and are a property of that component. An end condition solution can intercept multiple targets and target types. For example when designing a special ditch, the sideslope condition “targets” the special ditch profile elevation, and then intercepts the original ground terrain model to form the ditch bottom and backslope.

5.8.2 End Condition Settings

End conditions will draw based on the targets and settings set. These settings are considered specifically end condition properties and are enabled/disabled through the point property dialog box. The end condition settings are described below.

**Check for Intersection** – when set, the line segment will search for the specified target. If not set, the line segment will be created at its full width regardless of whether it intersects the target, provided that one of the segments connected to this segment successfully intersects the target.

**Place Point at Interception** – when set, a point will be placed at the location of the interception. If not set, the line segment will be created at its full width, provided that one of the segments connected to this segment successfully intersects the target.

**End Condition is Infinite** – when set, the line segment will automatically be extended to intercept the target. If not set, the line segment will only extend to its maximum constraint to meet its target. This applies only to the last line segment in an end condition.
Do Not Construct - If set, the end point of the line segment will be used as a reference point to find a subsequent point. The point will be solved like any other end condition point, but that point will be skipped when drawing the final component segments. This is normally not set and is used only for more complex condition testing.

5.8.3 Testing End Conditions

Testing end conditions gives the user the ability to verify the solutions and priorities as well as testing multiple targets without using the Create Corridor tool.

When creating end conditions, the user should test to see if desired results are generated. This can be done before, during or after creation of the end condition.

5.8.4 Basic End Conditions Creation Workflow

1. Open a template library
2. Navigate to the folder where templates will be stored
3. Select create template
4. Create a new template
5. Create end condition components
6. Test end conditions
7. Save the template library
5.9 Group Exercise 3-1: Creating a Constrained Component - Curb

1. Within the data_05\data folder, open the PlanJ2P0200.dgn.

2. From the Corridor Modeling task group, select the Create Template icon.

3. Select File > Save As from the Create Template dialog menus. Save the workspace template library to J2P0200.itl in the Randolph\J2P0200\Data_05 folder.

4. Right click on the file path at the top of the dialog and create the following folder structure:

   J2P0200 > Components > Curb

5. Within the Curb folder, create a new template named Curb.

6. If the Dynamic Settings dialog is not displayed, select Tools > Dynamic Settings. Set the step increment to 0.10.

7. If not set, toggle ON the Display Point Names check box in Create Template dialog.

8. Right-click on the Current Template window and select Add New Component > Constrained.
9. Setup the Current Component portion of the Create Template dialog as follows:

- **Component Name**: CONCRETE CURB
- **Feature**: XS_Curb_Surface

10. Setup the Dynamic Settings dialog as follows:

- **Point Name**: SHDR (key in)
- **Style**: XS_Curb_Surface
- **Apply Affixes**: Disabled
- **Precision Input**: $x, y = 0, 0$
- Press the **Enter** key

**Notes:**

- The default units for precision input are feet. You can enter other units with the proper specification, such as 6" instead of 0.5.
- Watch the prompts in the lower left corner of the Create Template dialog.
- When creating a component using precision key-in, an ESC allows you to go back.
11. Setup the Dynamic Settings dialog as follows:
   - **Point Name**: TOC (key in)
   - **Style**: XS_Curb_Surface
   - **Apply Affixes**: Disabled
   - **Precision Input**: \( xy = 0.07, 0.5 \) (from similar triangles)
   - Press the Enter key

12. Setup the Dynamic Settings dialog as follows:
   - **Point Name**: BOC (key in)
   - **Style**: XS_Curb_Surface
   - **Apply Affixes**: Disabled
   - **Precision Input**: \( hs = 5.5", 0.0 \)
   - Press the Enter key

13. Setup the Dynamic Settings dialog as follows:
   - **Point Name**: BOC_BOT (key in)
   - **Style**: XS_Curb_Surface
   - **Apply Affixes**: Disabled
   - **Precision Input**: \( dl = 0.0, -16" \)
   - Press the Enter key

14. Setup the Dynamic Settings dialog as follows:
   - **Point Name**: TOC_BOT (key in)
   - **Style**: XS_Curb_Surface
   - **Apply Affixes**: Disabled
   - **Precision Input**: \( dl = -7.75", 0 \)
   - Press the Enter key

15. Right-click on the *Current Template* window and select **Finish**.

16. Enable the **Display Point Names** option.

17. Save the template library.
5.10 Group Exercise 3-2: Creating an End Condition

1. From the Corridor Modeling task group, select the Create Template icon:

   ![Create Template Icon](image)

1. Select File > Open from the Create Template dialog menus. Open template library named J2P0200.itl from the J2P0200/Data folder.

2. Navigate to the J2P0200 folder and create a new folder called End Conditions.
3. Within the **End Conditions** folder create a new template called **Slopes (6:1)**.

4. To create the new slope component, right-click on the *Edit Template* Window and select **Add New Component > End Condition**.

5. Setup the **Current Component** portion of the *Create Template* dialog as follows:

   - **Name:** Fill
   - **Feature:** XS_Ground_Proposed
   - **Target Type:** Terrain Model
   - **Priority:** 1
   - **Terrain Model:** <Active>
6. For the first point setup the **Dynamic Settings** dialog as follows:

   - **Point Name:** Fill_Slope_T (select from list)
   - **Point Style:** XS_Ground_Proposed
   - **Apply Affixes:** Disabled
   - **Precision Input:** xy = 0,0

![Dynamic Settings dialog](image)

7. With your cursor in the \(xy=0,0\) field, press the **Enter** key on your keyboard.

8. For the second point setup the **Dynamic Settings** dialog as follows:

   - **Check for Interception:** Enable
   - **Place Point at interception:** Enable
   - **End Condition is Infinite:** Enable
   - **Do Not Construct:** Disabled
   - **Point Name:** Fill_Slope_B (pull-down)
   - **Point Style:** XS_Ground_Proposed
   - **Apply Affixes:** Disabled
   - **Precision Input:** \(hs = 30, -1:6\)

![Dynamic Settings dialog](image)

With your cursor in the \(hs = 30 -1:6\) field, press the **Enter** key on your keyboard.

9. Right-click on the **Edit Template** window and select **Finish**.

10. Create Ditch End Components by right-clicking in the **Current Template** window and select **Add New Component > End Condition**.
11. Setup the Current Component portion of the Create Template dialog as follows:

**Name:** Ditch  
**Feature:** XS Ground Proposed  
**Target Type:** Terrain Model  
**Priority:** 1  
**Terrain Model:** <Active>

![Current Component Dialog](image)

12. For the first point setup the *Dynamic Settings* dialog as follows:

**Point Name:** Ditch_Frslp_1_T (select from list)  
**Point Style:** XS_Ground_Proposed  
**Apply Affixes:** Disabled  
**Precision Input:** xy = 0,0  

![Dynamic Settings Dialog](image)

With your cursor in the xy=0,0 field, press the **Enter** key on your keyboard.
13. To place the **Fore-Slope bottom** point, set the *Dynamic Settings* dialog as follows:

- **Point Name**: `Dtch_Frslp_1_B` (select from list)
- **Check for Interception**: Disabled (this forces this line segment to be placed)
- **Place Point at Interception**: Disable
- **End Condition is Infinite**: Disabled
- **Do Not Construct**: Disabled
- **Apply Affixes**: Disabled
- **Precision Input**: `hs = 24,-1:6`

With your cursor in the `hs = 24,-1:6` field, Press the **Enter** key.

14. To place the **Back of Ditch bottom** point, set the *Dynamic Settings* dialog as follows:

- **Point Name**: `Dtch_Bkslp_1_B` (select from list)
- **Check for Interception**: Disabled (This forces this line segment to be placed)
- **Place Point at Interception**: Disable
- **End Condition is Infinite**: Disabled
- **Do Not Construct**: Disabled
- **Apply Affixes**: Disabled
- **Precision Input**: `hs = 4,0`

With your cursor in the `hs = 4,0` field, Press the **Enter** key.
15. To place **Slope-Stake point**, set up the **Dynamic Settings** dialog as follows:

- **Point Name:** Dtch_Bkslp_1_T (select from list)
- **Check for Interception:** Enable
- **Place Point at Interception:** Enable
- **End Condition is Infinite:** Enable
- **Do Not Construct:** Disabled
- **Apply Affixes:** Disabled
- **Precision Input:** hs = 5.25%

With your cursor in the $hs = 5.25\%$, press the **Enter** key.

16. **Right-click** on the **Edit Template** window and select **Finish**.

17. Select **File > Save** to save the template library.

18. Test the End Conditions by selecting the **Test** button located under the **Current Template** window. A warning will be given about the template having end condition priority conflicts.

19. Select **Check Priorities** on the right side of the **Test End Conditions** window.
Notice the Fill_Slope_T point is the point that has the priority conflicts.

20. In the End Condition Priorities dialog select Edit.

Notice that all the end conditions have the same priority number.

Put your cursor in each of the fields and notice the segments highlighting.

Assume that fill is the most desirable condition and change the Priority of the Ditch (or Cut) to 2.

21. Click OK, and then Close.

22. Click Draw on the right side of the Test End Conditions window. Move your cursor over the end conditions.

23. Close the Test End Conditions dialog. Save the Template Library by selecting File > Save.

24. Close the Create Template dialog.
5.11 Individual Exercise 3-3: Creating an End Condition

1. From the Corridor Modeling task group, select the Create Template icon:

2. Select File > Open from the Create Template dialog menus. Open the template library named J2P0200.itl from the J2P0200/Data folder.

3. Navigate to the J2P0200 > End Conditions folder and create a new template called Fill (4:1) Cut (3:1)
4. Create **Fill End Components** by right-clicking on the Template Window and select **Add New Component > End Condition**.

In this exercise the design criteria calls for a **4:1 Fill and 3:1 Ditch slope**.

Using the previous exercise create the following two end conditions. Also test end conditions to make sure there are no conflicts.
5.12 Group Exercise 3-4: Creating a Template

1. From the Corridor Modeling task group, select the Create Template icon:

![Create Template Icon](image)

2. Select File > Open from the Create Template dialog menus. Open the template library named J2P0200.itl from the J2P0200/Data_05 folder.

3. Navigate to the J2P0200 folder and create a new folder called Road1.

![Create Template Dialog](image)

**Note:** In this exercise the User will create a template similar to the Two Lane Rural typical listed on the following page.
4. Within the Road1 folder, create a new template called Road1 Two Lane Rural by right clicking on the Road1 folder and selecting New > Template.

5. Set the following Dynamic Settings:
6. In *Create Template* go to **Tools > Options** and confirm the following Affixes are set:

![Image of Template Options dialog box with highlighted Apply Affixes and Prefix fields]

7. In *Create Template* select the **Components > Pavement - New > Pavement Only > Asphalt > Asphalt Pavement** component.

When placing the component, right click and select **Mirror** then place the component at the 0,0 coordinate.

![Image of Create Template dialog box with selected components]

8. Select the **Components > Shoulders > Aggregate and Rock Fill Bases > Aggregate Base** component.
9. Place the shoulder component at the **RT_AsphSurf_T_EOP** location.

10. Modify the two lower inner shoulder point constraints to follow the pavement wedge slope.

11. Double click on the point **RT_AggBase_B_EOP**. This will bring up the *Points Properties* dialog where you can edit the detail of the point.
12. In the *Point Properties* dialog, adjust the constraint that controls the **Horizontal Control** to a **Vector-Offset**. Set the *Parent* points to be the top and bottom pavement points (See below), also set vector offset *Value*: to **0.0**. Modify both shoulder points.

14. In the *Create Template* dialog, select the **End Conditions** > **Ditches** > **Ditch 1** end condition, and then place the ditch component at the RT_AggBase_T_EOS location.

15. Next, select the **End Conditions** > **Fill Slopes** > **Fill Slope Combined** component then place this fill component at the RT_AggBase_T_EOS location.
a. In Create Template select the Test button to view the End Condition Priorities.

b. Save Template Library.
5.13 Individual Exercise 3-5: Creating a Template

1. From the Corridor Modeling task group, select the Create Template icon:

2. Select File > Open from the Create Template dialog menus. Open the template library named J2P0200.itl from the J2P0200/Data_05 folder.
3. Navigate to the J2P0200 > Road1 folder and create a new template called Road1 Two-Lane Urban by right-clicking on the Road1 folder.

4. Set the following Dynamic Settings:

5. In Create Template go to Tools > Options and confirm the following Affixes are set:
6. In **Create Template** use the following components to create the **Road1 Two-Lane Urban** template:

**Components:**

<table>
<thead>
<tr>
<th>Left Side</th>
<th>Right Side</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concrete Pavement w/ Agg Base</td>
<td>Concrete Pavement w/ Agg Base</td>
</tr>
<tr>
<td>Curb and Gutter Type B w/ Agg Base</td>
<td>Curb and Gutter Type B w/ Agg Base</td>
</tr>
<tr>
<td>Sidewalk w/ Outer Buffer</td>
<td>Berm (1%)</td>
</tr>
<tr>
<td></td>
<td>(Sloping down away from gutter)</td>
</tr>
</tbody>
</table>

**End Conditions:**

<table>
<thead>
<tr>
<th>Left Side</th>
<th>Right Side</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fill Slope Combined</td>
<td>Fill Slope Combined</td>
</tr>
<tr>
<td>Ditch 1</td>
<td>Ditch 1</td>
</tr>
</tbody>
</table>

*Notes

a) Concrete Pavement w/ Agg Base is located in the following location:

   **Components > Pavement New > Pavement Only > Concrete**

b) Merge the vertical line between common components.

c) Make the concrete thickness **9-3/4” (-0.8125”)** before adding **Curb and Gutter Type B w/ Agg Base**. If you already place the Curb and Gutter select “Undo”.

d) Check Priorities on End Conditions

e) Save Template Library
Practice #2 - Adding a Constrained Component

Curb & Gutter Detail

CONCRETE CURB & GUTTER

0.05 FT/FT

SHDR BOT

0.05 FT/FT

SHDR

GUTTER

0.02 FT/FT

TOC

BOC

SW_BK

SW_BK_BOT

1’ - 0”

CONCRETE SIDEWALK

6’’

3’ - 0”

5”

6 1/2''

1’ - 6”

4’’