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2.1 Objectives 

 Understand and use Feature Definitions 

 Create PI based horizontal geometry using the Complex by PI tool 

 Use the OpenRoads Technology heads-up display and element manipulators 

 Associate Design Standards with alignment geometry and review feedback when design 

standards are violated 

 Import geometry from native geometry database 

 Discuss using manipulators and handlers 

2.2 Definitions 

Civil Geometry is a dynamic, interactive, rules-based approach to geometry that provides an 

unprecedented level of associativity by preserving design intent, snaps and Civil AccuDraw input. 

The results of the tools are intelligent MicroStation graphic elements which can be dynamically 

edited and associations between elements are automatically updated.   

In addition, the result of using the Civil Geometry tools are graphical geometry elements that are 

stored as MicroStation elements. No external geometry file is required. The MicroStation 

elements serve as the geometry elements with additional intelligence applied to store the rules and 

associations. 

The Civil Geometry tools are installed as a part of GEOPAK. In order to be consumed by 

processes within GEOPAK, the civil geometry stored in the MicroStation elements must be 

written to the native application coordinate geometry .GPK file. This function can be configured 

to happen automatically based on properties of feature definitions, or it can be done manually. 

2.2.1 Coordinate System 

The Coordinate system is defined with XYZ Coordinates.  The X and Y Coordinates define a 

horizontal plane, while the Z Civil defines the vertical dimension.  All points in a civil geometry 

element are defined by at least an X coordinate and a Y Coordinate.  If an elevation is to be 

stored, the Z Coordinate will also be defined. 
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The XYZ Coordinates can also be referred to in Northing (N), Easting (E), and Elevation (Z) 

Coordinates.  The Northing Civil refers to the Y value, the Easting Civil refers to the X value, 

and the Elevation refers to the Z value. 

 

The user must be aware of the Coordinate system the data is in, and the Coordinate system that 

GEOPAK is using.  When referring to the XYZ coordinate system, the Coordinates are listed as 

(X, Y, Z).   When referring to the Northing, Easting, Elevation coordinate system, the 

Coordinates are listed as (N, E, Elev.).  When translating this to the XYZ coordinate system, the 

Coordinates would be (Y, X, Z). 

2.2.2 Points 

Points are defined by a single set of Coordinates.  Each point will have an X and a Y Coordinate.  

The point may also have a Z coordinate if an elevation is defined.   

Point names are alpha-numeric.  If alphabetic characters are used, they must come before any 

numeric characters.  The point name must contain at least 1 numeric character at the end of the 

name.  Names can be up to 15 characters in length, although limiting the name to 8 characters is 

recommended. 

Points can be stored from a set of Coordinates, or located from other elements.  To define a point 

from another point, a distance and direction need to be defined. 
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Modifiers can be added to the direction and distance.  An offset can be applied.  This will locate 

the point at the specified distance and direction from the starting point, then perpendicular to the 

specified direction for the specified offset distance.  A positive offset will go to the right of the 

specified direction, and a negative offset will go to the left of the specified direction. 

 

2.2.3 Lines and Linear Elements 

Lines are defined by a location point and a direction, and are infinite in length. 

Civil Geometry Linear Elements are a portion of a line that is defined by a beginning and an 

ending point. 

Linear Element names can be alphanumeric up to 15 characters, but should not be numeric-alpha 

if the elements are going to be brought back to Native GEOPAK. 
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2.2.4 Curves 

Curves are a segment of a circular arc.  Curves can be defined by either the arc method (central 

angle that produces a 100’ arc) or chord definition (central angle that produces a 100’ chord).  

MoDOT uses the arc definition for all new alignments; however the chord definition has been 

used in the past, and may still be shown on old plans.  This is configured in design file settings > 

Civil Formatting. 

A curve has several points associated with it.  These points help to define the curve, and are 

stored automatically when the curve is stored. 

PC – Point of Curvature; Beginning of the curve. 

PT – Point of Tangency; End of the curve. 

PI – Point of Intersection; Point where the two tangents meet. 

CC – Circle Center; Point at the center of the circle from which the curve is segmented. 

 

Curve names can be any alpha-numeric characters up to 15 characters in length to be honored 

when brought back to Native GEOPAK. 

2.2.5 Spirals 

Spirals are a transitional curve.  Typically a spiral will transition from a tangent (infinite radius) 

to a specified radius defined by a curve.  Spirals can also transition between 2 specified radii as 

defined by 2 curves. 
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Spiral names can be any alpha-numeric characters up to 15 characters in length to be honored 

when brought back to Native GEOPAK. 

Several points are also stored with a spiral.  They are as follows: 

TS – Tangent to Spiral Point 

SC – Spiral to Curve Point 

CS – Curve to Spiral Point 

ST – Spiral to Tangent Point 

PISCS – Overall Point of Intersection for the spiral-curve-spiral combination. 

 

2.2.6 Chains 

Chains are a combination of other elements.  They can consist of points, curves, spirals, or other 

chains.  Chains can represent horizontal alignments, or the horizontal location of some element.  

Chains have stationing associated with them.  Locations along the chain can be determined by the 

stationing.  If the stationing is adjusted along the chain a station equation is used.  The stations 

from the beginning of the chain to the first station equation are referred to as Region 1.  The 

stations from the first station equation to the second station equation or the end of the chain are 

referred to as Region 2. 

 

Chain names can be any alpha-numeric characters up to a length of 15 characters. 

2.2.7 Profiles 

Profiles are vertical alignments defined by stations and elevations.  They are associated with 

some horizontal plan element.  Profiles can be stored with or without vertical curves.  Profiles 
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without curves generally represent the existing ground profile, or a ditch profile.  Profiles with 

vertical curves are generally used as proposed corridor. 

 

2.3 Open Roads Preferences 

The seed files delivered in the workspace have MoDOT design file preferences configured. 

2.3.1 Workspace Preferences 

This dialog provides settings for the cursor prompt, manipulators, and various operational toggles.  

Enable this dialog from the Workspace > Preferences menu and selecting the View Options-

Civil category. 

Manipulator Settings 

These settings allow the user to control the settings and symbology of the civil geometry 

manipulators and any associated text. 

Superelevation Settings 

When the super elevation components are drawn into the design file, these two options allow 

the user to specify whether they are to be drawn as Color Shaded Fill or Boundary Only. 

Survey Locator 

This setting is used by the Survey tools to control the display and symbology of the locator. 
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Maximum Error Ellipse 

Survey only - This setting allows the user to specify a major error ellipse value with regard 

to the standard deviation resulting from a Least Squares Adjustment. Any standard deviation 

exceeding this limit results in a graphical flag based on this symbology. 

Medium Error Ellipse 

Survey only - This setting allows the user to specify a medium error ellipse value with 

regard to the standard deviation resulting from a Least Squares Adjustment. Any standard 

deviation exceeding this limit results in a graphical flag based on this symbology. 

Minimum Error Ellipse 

Survey only - This setting allows the user to specify a minimum error ellipse value with 

regard to the standard deviation resulting from a Least Squares Adjustment. Any standard 

deviation exceeding this limit results in a graphical flag based on this symbology. 

2.4 Design File Settings 

  

Design File Settings dialog provides options for civil settings that control civil annotation within 

the design file. Enable this dialog from the Settings > Design File menu and selecting the Civil 

Formatting category. 

 Export Settings 

When Export to Native is set to Use Feature Setting, the native geometry database 

(.GPK, .ALG, .FIL) will sync with civil geometry stored within the design file. For 
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example, the user can store an alignment in the design file and that alignment will be 

automatically stored in the native geometry database as well. Delete an alignment 

from the design file, and that alignment will be deleted from the native geometry 

database. The Export to Native functionality is feature based in that the option to 

”Export to native” must be set to ”true” or ”false” for each particular feature. 

 

If Export to Native is set to Manual, the native geometry database will have to be updated 

manually. 

 Coordinate Settings 

Controls the display and precision of their coordinates within any of the civil dialogs. In 

addition, this setting also controls how any inputted coordinates are interpreted. For 

example, if set to “X, Y” then all coordinates are interpreted and displayed as being in 

the “X, Y” format. If set to “Nothing, Easting” then the same applies. 

 Ratio Settings (Distance:Offset) 

Controls the display and precision of ratios within any of the civil dialogs. In addition, 

this setting also controls how any inputted ratios are interpreted. For example, if set to 

“1:D” then all ratios are interpreted and displayed in this format (1:100, 1:50, etcetera). 

If set to “D:1” then the ratios are similarly displayed and interpreted (5:1, 10:1, etcetera). 

 Station Settings 

Controls the format, delimiter and precision of the station values to be used and 

displayed in the civil dialogs.  Equation can be set to: 

By Name - This is the standard InRoads presentation (A100+00, B105+00, etcetera). 

By Index - This is the standard GEOPAK presentation (100+00 R 1, 105+00 R 2, 

etcetera). 

 Radius Settings 

Degrees of Curve Method - Two options are available, Arc and Chord. 

Degree of Curve Length - This sets the standard definition of a 1 degree of curve. 

Radius Toggle Char - This allows the user to specify which character will be used 

within the civil dialogs to ‘toggle’ between a radius definition and a degree of curve 

definition. The letter d is the default setting. 

 Profile Settings - Controls the precision and display or input formats of slopes and 

ratios within a profile context. In addition, sets the default Vertical Curve Parameter 

Format (Radius, K Value or M Value). 
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2.5 Accessing 

When designing with the Open Roads technology in GEOPAK the geometric data can be written 

back to the native .gpk.  Having an active GEOPAK project facilitates this capability. 

To setup Coordinate Geometry project values, choose the GEOPAK > ROAD > Geometry 

>Coordinate Geometry command and the data in the Coordinate Geometry dialog as noted 

below. 

  

 Project Name: defines the name displayed on reports (60 alphanumeric characters max) 

(Optional). 

 Job: identifies the Civil geometry database (3 alphanumeric characters, max) (Required). 

 Operator Code: identifies a unique 2-character operator code.  Allows multiple user 

access to the database. (Required) (User’s initials suggested). 

 Subject: description of work (48 alphanumeric characters, max) (Optional). 

Once these parameters have been defined, the Coordinate Geometry dialog box will appear. 
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2.6 Features and Feature Definitions  

Access the Feature Definitions Toggle Bar from the Horizontal Geometry tasks group.  

 

Having the Definitions Toggle Bar open and available is very useful for expediting the association 

of a feature definition to a new geometry feature. 

 

Feature definitions are used to define options when creating features. These are the items which 

are created in advance, usually used across multiple projects, and define symbology, annotation 

and quantities. The feature definition is assigned (usually) in the plan model, and optionally in 

profile and 3D feature definitions. 

A Feature is anything that can be seen or located and is a physical part of your design representing 

a real world entity. Examples include curb and gutter, pavement, power lines, trees, etc. 

A feature’s definition is one of its properties. At any given time in the design process, the feature 

will have horizontal geometry, vertical geometry, 3D geometry or a combination to define its 

location. Generally, the feature’s definition is assigned at time of creation, but can be assigned 

after-the-fact. 

Most Civil tools have entry fields for Feature Definition in their dialog as illustrated below. 
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The rules applied to Feature Definitions are: 

 If no Feature Definition is selected, the active MicroStation symbology is used and no 

feature is defined, but you can define a Name Prefix. 

 If a Feature Definition is assigned, a Name Prefix is applied, and the symbology, 

attributes, and annotation defined in the feature definition are applied to the element. 

2.7 Design Standards 

Design standards are used to monitor required curvature and other alignment checks on horizontal 

Civil Geometry elements and slopes and K values on vertical geometry elements.  The standards 

are stored in a design library (DGNLIB) which can be read-only and stored in a central location 

for use by all users and referenced by the configuration variable MS_DGNLIBLIST. A DGNLIB 

is an empty file (does not contain any MicroStation elements) similar to a seed file where you can 

set up various MicroStation and Civil resources. An organization can utilize numerous DGNLIBs 

to facilitate management of their standards. For example, horizontal and vertical standards could 

be stored in one DGNLIB while other standards would be defined in other DGNLIBs. If utilizing 

both Metric and English units, you may want a separate DGNLIB for each. 

The standards are set up within the Project Explorer. Note the hierarchy from the Project Explorer 

is mirrored in the Design Standards Tool Bar pick lists. The hierarchy is customizable to conform 

to your organization’s standards.  As most organizations utilize AASHTO standards, the default 

libraries included in the installation package are based on the 2001 and 2004 versions of  ”A 

Policy on Geometric Design of Highways and Streets.” 

The Project Explorer is accessed by selecting File > Project Explorer from the main menu or 

from the Primary Tools menu bar. It is more efficient to complete the vertical standards first, as 

they are referenced when building the horizontal standards. 
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Right-click on the individual entry and select Properties from the pop-up menu to review the 

settings. 

 

Horizontal Design Standards Properties 
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Vertical Design Standards Properties 

2.8 Viewing and Accessing Horizontal and Vertical Standards 

The Design Standards branch lists the design standards that are available within the active design 

model or a DGN library. The Design standards defines Design standards that are used to assist the 

designer in maintaining required curvature and other checks when performing geometric layouts 

and are normally based on accepted standards for a geographic area or authority, these standards 

are stored in DGN libraries. 

  

The properties for each Horizontal standard are: 

 Design Values 
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Speed - this is the design speed for the standard. 

Default Radius - this is the radius used to populate commands when initiated. 

Minimum Radius - this is the minimum radius for the corresponding design speed.  

Utilizing values lower than this radius will cause a warning to be displayed. 

Transition Type - can be by Table or Equation. 

Table - If transition type is table then this is used to populate the table.  

Include Transitions 

Check Tangency 

 Arcs 

Maximum Arc Length 

Minimum Arc Length 

 Tangents 

Maximum Tangent Length 

Minimum Tangent Length 

Maximum Deflection - the maximum angle between the lines where two tangents join 

without a curve. 

The properties for each Vertical standard are: 

 Vertical Design Standards 

Minimum slope 

Maximum slope 

Maximum difference in grade 

Vertical Table Type 

Table  
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2.9 Civil AccuDraw 

Civil AccuDraw performs many of the same functions as MicroStation AccuDraw but has greatly 

expanded capabilities for the civil designer. It allows the user to define a point location at any 

stage of any placement tool (MicroStation or Open Roads) and accept input that results in more 

sophisticated point locations. 

  Accessing Civil AccuDraw 

Civil AccuDraw can be accessed from Tools> Civil AccuDraw > Activate Toolbar or from the 

Civil Tools task menu General Geometry > Activate Civil AccuDraw Toolbar. 

 

It is recommended that the Civil AccuDraw Toolbar be docked to facilitate use. 

 

The shortcuts have key-ins and are also mapped to icons.    Having the Shortcuts Toolbar 

active and docked can also be a time saver. 

 

Benefits 

There are many benefits in using Civil AccuDraw. 

1. It extends the drafting power of MicroStation by providing Civil point location 

methodologies in all the MicroStation and Civil commands. For example, a user will be 

able to place a cell at an offset using the normal place cell but invoking Civil AccuDraw 

to enter the station and offset. 

2. It will eliminate the need to create temporary construction geometries just to perform 

more complex point locations. For example, to place a line at a given distance from 2 

points a user would need to draw 2 circles at each point with the desired offset as the 

radius of each station and then place a line tangent to these circles, and finally delete the 
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unwanted circles. Civil AccuDraw provides a Distance from Point snap where the point 

can be identified, the offset entered, and the data point applied to the construction. 

3. When used in conjunction with the Civil Geometry commands the resultant elements are 

constrained by rules set by the selection of the Civil AccuDraw ordinates. 

4. The Civil Geometry heads up display options are enhanced when Civil AccuDraw is 

active and the options available are determined by the method selected. 

Use Tips with the Geometry commands 

1. Selecting the Tab key while in an entry field will change focus. 

2. Selecting Enter will set the value in the field and lock it 

3. Selecting the End key will unlock the field 

4. Selecting the left or right arrow key will move through the favorite options. 

5. Selecting the down key will bring up the associated command entry dialog in addition to 

the heads up display. 

2.9.2 Civil AccuDraw Overview 

1. Open any Design file (.dgn) file.  

2. To open the Civil AccuDraw Toolbar, select Tools > Civil AccuDraw > Activate 

Toolbar 

 

The Civil AccuDraw toolbox will open. 

 

 Toggle Civil AccuDraw on/off. 
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 Drop down list of various tools including Civil AccuDraw settings and common 

shortcuts.  This drop-down is also available by pressing space bar when any Civil 

AccuDraw field has focus. 

 

These are the ordinate systems delivered in a default installation.   

 Distance – Direction 

 Distance – Direction Unlinked with two origin points 

 Distance – Distance 

 X – Y 

 Dx – Dy 

 Station – Offset 

 DeltaStation-Offset 

In a three dimensional design file there are two additional icons 

 Sets the elevation ordinate 

 ProfileOffset. 

Some differences between the MicroStation AccuDraw tool and the Civil AccuDraw tool:  

a. Civil AccuDraw compass will always point north regardless of view rotation. 

b. Civil AccuDraw uses a heads-up on-screen prompt at the cursor to allow precise key-

in of distance and direction.  A fixed dialog box becomes available when the down 

arrow is selected. 

c. The Civil AccuDraw compass will always be circular.  MicroStation AccuDraw 

changes the compass to rectangular for Cartesian ordinate systems. 

 Civil AccuDraw Settings 

The Operation tab is similar to that of MicroStation 

AccuDraw. 

 Operations of the same name have the same 

function in both AccuDraws. 

 Selection or de-selection in one AccuDraw 

does not affect the selection in the other 

AccuDraw. 

 Selecting the Show AccuDraw Dialog will 

result in the dialog and the heads up display 

both being available to the user during 

element placement. 
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The Display tab contains settings for: 

 Color of compass axis 

 Points configures the number of points in the compass circle 

 Color of the constraint lines 

 Whether you want to see the constraint lines and color of the constraint lines 

 

The shortcut button brings up the same shortcut list as used by MicroStation AccuDraw. 

Both AccuDraws access the same shortcut.txt file. 

The Coordinates tab contains the same round off and 

indexing settings as MicroStation AccuDraw and 

function the same way.   

 Civil AccuDraw has additional settings that are 

provided to allow the round off of station and 

offset values. 

 The numbers must be changed to values other 

than zero to be accepted. 
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The Favorites tab allows for the configuration of the most commonly used ordinate systems.  It is 

one of the primary differentiators between Civil AccuDraw from MicroStation AccuDraw.    The 

favorite selected determines what input fields are available during the placement of an element. 

 

Ordinate 1 and Ordinate 2 are the measurement methods used in determination of the 

coordinates. 

Common Origin has a Yes/No option. 

 Yes indicates that both ordinate measurements come from the same origin location. 

 No indicates each ordinate has a different location.    

To add a new favorite: 

1. Select Add 

2. Key in the Name  

3. Select the Ordinates. 

4. Select whether the ordinates share a common origin. 

2.9.3 Simple Linked Favorite Civil AccuDraw Workflow  

A Linked favorite has two ordinates or measurement methods that share the same Point of 

Beginning (POB) or Origin.  
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1. Ensure Civil AccuDraw is active.  If it is active then the first icon in the toolbox will have 

an orange background. 

2. Set the active symbology or active 

feature.  If no feature is assigned, 

the element will use Default. 

3. Start the tool of interest and place 

the first point.  This can be by XY= 

key-in or a data point.  If the Civil 

AccuDraw XY favorite is active 

the X and Y fields will be available 

in the heads up display. 

4.  Select the Dist-Dir favorite. 

Entries in the distance and 

direction fields present a dynamic 

circle and line feedback for the 

constraints. 

5. Key in a distance and then press the Enter key to lock the distance. 

6. As the cursor moves over one of the compass points (north, south, east or west) there is a 

color change feedback indicating a compass direction locks. 

7. To unlock a value use the End key. 

8. Data Point to accept the value. 

2.9.4 Simple Un-Linked Favorite Civil AccuDraw Workflow 

An Un-Linked favorite has two ordinates or measurement methods each with a unique Point of 

Beginning (POB) or Origin. 

 

1. Ensure Civil AccuDraw is active.  If it is active then the first icon in the toolbox will have 

an orange background. 

2. Select an element placement command. 

3. Set the active symbology or active feature. 

4. Start the tool of interest for example Distance-Direction.  

5. Place the first point.  This can be by XY= key-in or a data point.  If the Civil AccuDraw 

XY favorite is active the X and Y fields will be available on the Heads Up Display. 

6. With the focus in the distance field press the letter (O) on keyboard. Then left click on 

the position to set the origin for measuring distance.  This could be a graphical element, a 

terrain Model element, a Civil Geometry Element or a data point. 
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7. The origin shortcut (O) in Civil AccuDraw waits for a data point before setting the origin.  

This is to provide capability for the (O) shortcut to also choose the baseline for station 

offset ordinates. 

8. Select the Tab key to move focus to the direction field, press (O) again, identify the 

location for the second ordinate point of beginning, and click a second data point to set 

the direction origin.  This results in two independent compasses to measure the distance 

and direction.  Both distance and direction can be locked as needed. 
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2.9.5 Station-Offset Linked Favorite  

The Station and Offset linked favorite pulls the station and offset from the element identified 

after the origin shortcut (O) is entered.  Selecting Tab will lock the value. 
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2.10 Civil Horizontal Geometry Commands 

Civil Horizontal Geometry commands can be accessed by selecting the Horizontal Geometry 

task group from the Civil Tools tasks menu. 

 

or by selecting Tools > Civil Geometry > Horizontal Tools > Open as Tool Box from the 

MicroStation menu. 
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2.10.1 Placing Point Geometry 

There are two point options; Place Point and Equal Space Points.  

 Place Point constructs a civil point element. The point may place a cell based on feature 

definition or a MicroStation point (zero length line) if no feature definition is used. 

1. Open the Civil Tools task pane to the Horizontal Geometry section then click the Point 

icon. Selecting the Point icon will open the Point dialog.  A 3D point can be created if 

given an elevation.  Check the Want 3D Point box and enter an Elevation in the field 

provided if you wish your point to have a vertical value. 

 

2. When you move the cursor into the View, it is equipped with a command prompt that 

says, Enter Data Point, so move the cursor to the location then place the data point to 

accept, or enter the XY value of the location in the MicroStation key-in field. 

 

 Equal Space Points inserts a specified number of 

points, points at a defined interval, or a combination of 

both into the View.  These can be along an element or 

between two points. 
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General Workflow 

1. First select the Placement Method (Between Points or Along Element). 

2. When using the Placement Method Between Points, select the location of the start point 

and key in the number of points.  Select the location of the end point. 

3. When using the Placement Method Along Element, select the element and select the 

Spacing type (Number Of Points option, Interval, Even, or Max Interval),  key in the 

Interval or Number Of Points, and finally key in the Offset from the element 

2.10.2 Placing Line Geometry 

There are five linear element placement options 

 

   Line Between Points – Places a line by Distance and Direction.    

The points can be defined in several ways: 

 Arbitrary Data Points on the screen 

 Using Civil AccuDraw 

 Snapped relative to other elements 

 Previously created geometry point element 

 Any of the values may be locked in the dialog when the tool starts or at any time while 

the tool is active. All of the values on the dialog are dynamically updated as the cursor 

moves 

Without Civil AccuDraw active, the start point is identified and the distance and Direction entered 

to place the second point. 

With Civil AccuDraw active and the XY favorite selected, a heads up prompt will provide XY 

key-in fields. 

 

Changing the AccuDraw favorite will also change the heads up display presenting fields to define 

the location of the end point.  If Linked Distance-Direction is selected in Civil AccuDraw then 

heads up display will have those fields. 
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 Line To Element – This is a series of Line To Element commands indicated by the arrow in 

the right hand corner of the icon.  These pre-customized versions provide a simplified prompt 

sequence for many common construction tools. Right-click on the Line to Element icon then 

choose Show/Hide Arc from Element Tools to access the following options. 

 Simple Line To Element - Creates a line without any transition to another element at 

zero degrees skew angle; applicable only when the To element is a curve, Offset locked at 

zero. 

 Spiral Line To Element - Creates a line with a spiral transition to another element at 

zero degrees skew angle; applicable only when the To element is a curve, Offset locked at 

zero. 

 Curve Line to Element - Creates a line with an arc transition to another element at zero 

degrees skew angle; applicable only when the To element is a curve, Offset locked at zero. 

 By Angle Line to Element - Creates a line without any transition at user defined skew 

angle, Offset locked at zero. 

 Line to Element - Creates a line at a skew to a reference element. 

 Line From Element – This is a series of Line From Element commands indicated by the 

arrow in the right hand corner of the icon.  These pre-customized versions provide a simplified 

prompt sequence for many common construction tools. Right-click on the Line From Element 

icon then choose Show/Hide Arc from Element Tools to access the following options. 

 Simple Line From Element - Creates a line without any transition from another element 

at zero degrees skew angle, Applicable only when the From Element is a curve, Offset locked 

at zero 

 Spiral-Line From Element - Creates a line with a spiral transition from another element 

at zero degrees skew angle, applicable only when the From element is a curve, Offset locked 

at zero 

 Curve-Line From Element - Creates a line with an arc transition from another element 

at zero degrees skew angle, applicable only when the From element is a curve, Offset locked 

at zero 

 By Angle Line From Element - Creates a line without any transition from another 

element at a skew angle you define, Offset locked at zero 
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 Line From Element - Creates a line at a skew from a base element. 

 Line Between Arcs - Constructs a line between two previously placed arcs. This tool has 

the ability to optionally apply a back and/or forward transition between the arc(s) and constructed 

line. 

 Chamfer Between Elements - Planes a corner (i.e., it alters an existing intersection by 

inserting a line between the elements). 

2.10.3 Placing Arc Geometry 

 Circle - Creates a circular element based on the center point of the circle and a through point 

defining the radius. 

 Arc Between Points - Creates an arc between points. The most common usage is Arc 

between 3 points, but other variations are available. Points can be defined in several ways: 

 Arbitrary Data Points on the screen 

 Defined using Civil AccuDraw 

 Snapped relative to other elements 

 An existing geometry point element 

 Simple Arc To Element – This is a series of Simple Arc To Element commands indicated 

by the arrow in the right hand corner of the icon.  These pre-customized versions provide a 

simplified prompt sequence for many common construction tools. Right-click on the Simple Arc 

To Element icon then choose Show/Hide Arc to Element Tools to access the following options.  

 Simple Arc To Element - Constructs an arc to element with a given radius 

 2 Center Arc To Element - Constructs an arc to element with a given radius and a back 

transition 

 Spiral Arc To Element - Constructs a spiral to element 

 Reverse Spiral Arc To Element - Constructs a Double Spiral to an element 

 Arc To Element - Constructs an arc to element with a given radius with the addition of 

offset and end tangent direction 
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 Simple Arc From Element – This is a series of Simple Arc From Element commands 

indicated by the arrow in the right hand corner of the icon.  These pre-customized versions 

provide a simplified prompt sequence for many common construction tools. Right-click on the 

Simple Arc From Element icon and then choose Show/Hide Arc From Element Tools to access 

the following options: 

 Simple Arc From Element - Constructs an arc from an element with a given radius. 

 2 Center Arc From Element - Constructs an arc from an element with a given radius 

and a back transition. 

 Spiral Arc From Element - Constructs a spiral from an element.  

 Reverse Spiral Arc From Element - Constructs a Double Spiral from an element. 

 Arc From Element - Constructs an arc from an element with a given radius with the 

addition of offset and end tangent direction. 

  Simple Arc – This is a series of Simple Arc commands indicated by the arrow in the right 

hand corner of the icon.  These pre-customized versions provide a simplified prompt sequence for 

many common construction tools. Right-click on the Simple Arc icon then choose Show/Hide 

Arc Tools to access the following options.  

 Simple Arc - Creates a radius arc without spirals or tapers at both ends, Offsets locked 

at zero 

 Spiral-Arc-Spiral - Creates a radius arc with spiral transitions but no tapers at both 

ends, Offsets locked at zero 

 Taper Arc Taper - Creates a radius arc with tapers but no transitions at both ends, 

Offsets locked at zero 

 3 Center Arc - Creates a radius arc with radius transitions at both ends, result is a three 

centered curve, Offsets locked at zero 

 2 Center Arc - Creates a radius arc with radius transitions at one end, result is a two 

centered curve, Offsets locked at zero 
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 Arc Between Elements - Constructs an arc between two previously placed elements. 

This tool has the ability to optionally apply a back and/or forward transition and/or taper 

between the elements and the constructed arc. 

 Arc Between Arcs - Constructs an arc between two previously placed arcs. This tool has the 

ability to optionally apply both a back and/or forward transition between the base arcs and the 

constructed arc. 

 Complex Transition between any Element and Arc - Constructs an arc between two 

previously placed elements. This tool has the ability to optionally apply a Back Spiral and/or 

Ahead Transition between the elements and the constructed arc. 

2.10.4 Placing Spiral Geometry 

 Spiral From Element - Constructs a spiral from a previously placed element, using this 

base element to determine tangency at one end. This tool provides chorded spirals only. Other 

spiral-like transitions are not supported. 

 

Spiral Between Elements - Constructs a spiral (or spirals) between two base elements 

that determine tangency. Dependent on the configuration of the base elements, there may be: 

 Single spiral that connects: A line and an arc 

 Two arcs where one arc is contained entirely within the circle of the other arc 

 A compound spiral between two arcs 

 A reverse spiral between two arcs 

This tool provides chorded spirals only. Other spiral-like transitions are not supported. 

2.10.5 Creating Complex Geometry 

  Complex By Elements - Constructs a complex element of previously placed elements by 

joining them in sequence. 

Workflow 

1 .  Click Complex By Elements. The Complex Element dialog displays.  

There are two methods of operation:  Manual and Automatic. 
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2. Using the Automatic method, hover over the beginning element until the directional 

arrow points to the desired direction. Left mouse-click to accept the chosen element. 

 

3. At this point, the complex path will be highlighted. Left-click again to accept the 

complex creation or right-click to cancel. 

 

4. Alternatively, using the Manual method, select each element individually using the left-

click. 

 Complex By PI - Creates a linear element with curves based on user input of PI (point of 

intersection) locations.  The curves can include transitions or set the transitions to none.  

The transitions on the curves can be arc transitions or chorded spirals using the following 

methods: 

 Spiral - Length 

 Spiral - A-Value 

 Spiral - Deflection 

 Spiral - Delta R 

 Spiral - RL 

 Curve - Length 

 Curve - Deflection 

 Curve - Delta R 

 Curve - Ratio 

To access these methods customize the dialog and add the 

method(s) of interest resulting in a customized tool.  

Workflow 

1. Click Complex By PI. The Complex Element By PI 

dialog displays. 

2. Select the Civil AccuDraw favorite to be used in 

placement of the PIs and key-in the placement values in 

the heads up display or Data point to set the beginning 

of the element. 

3. Place the second PI. 
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4. Place the third PI.  Radius always applies to the PI prior to the one where the data point 

is currently being set. You can edit the radius by keying in a new value in the prompt. If 

the back and ahead transitions are set then this is a triple toggle input. Toggle with left-

right arrow keys to set back and ahead transition parameters. 

5. Continue to data point to add more PI points. Click the Reset button to stop adding PI 

points. 

 Start Station - Assigns stationing to an element. You assign a station value and a position 

along the element for that station value. This command can be used on a civil element or a plain 

MicroStation graphic. If this command is never run, then the beginning stationing is assumed to 

be zero. 

 Add Station Equation - Defines a station equation at a designated location on an element. 

If stationing has not been previously defined, then a zero starting station is also assigned. This 

command can be used on a civil element or a plain MicroStation graphic. 

Preferences 

Preferences that affect Start Station and Add Station Equation are stored as DGN settings 

(Settings > Design File Settings > Civil Formatting). 

2.11 Editing Horizontal Geometry  

Once a Civil Geometry Element is placed, selection of that element will display the appropriate 

manipulators, defining the element.   
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Manipulators 

Manipulators are available for: 

 Distance and direction on each line segment 

 Radius and transition parameter on each curve 

 Drag handles at PI points 

 

Normal Line Manipulators 

When the line is placed without any snaps and without 

any Civil AccuDraw constraints, you will see the 

onscreen manipulators as shown right. These 

manipulators can be used to edit the line as follows: 

 The distance and direction text manipulators 

can be clicked to allow editing of the value 

 The arrows parallel to the line can be used to 

extend or trim the line (i.e., change the distance) 

 The end point arrows perpendicular to the line can be used to rotate the line (i.e., hold 

the distance and change the direction) 

 The perpendicular arrow at midpoint can be used to move the line parallel 

 The dot at the end points can be used to move the point without constraining the distance 

or direction 

 The dot at the midpoint can be used to move the line in its entirety 

Snap Manipulator 

When a line end point has been snapped, the normal 

manipulators are replaced by a snap manipulator. The end on 

the left was snapped by key point, so you see a single dot 

and an icon indicating the snap type.  
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You can move the snapped end in space by clicking the dot and dragging. This breaks the snap 

and creates a new endpoint location that might be a data point, a different snap or a Civil 

AccuDraw input. 

If you hover over the snapped end point dot, the normal manipulators will appear to allow 

extend/trim or rotate of the line. This also breaks the snap. Similarly, when a line endpoint is 

created by Civil AccuDraw, the normal manipulators are replaced by a single dot and the 

AccuDraw manipulators. The AccuDraw Manipulators are text labels that can be clicked and 

edited. 

Hover over the dot to show the normal manipulators for rotate and trim/extend functions. This 

replaces the AccuDraw input with the new input values. 
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2.12 Horizontal Geometry Properties 

The rule data is also accessible in the properties of the line. Select the line and click Properties 

from the heads up menu. Most data in the property pane can be edited to change the line 

definition.   You can also select the geometry using the Element Selection tool and use the 

Element Information dialog to make changes 

 

Note: When you review geometry the Element Information dialog displays the terrain models 

that the geometry belongs to, if any. 
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2.13 Individual Exercise 1: Route 24 

1. Create a new MicroStation file named Route24.dgn using the  

pw:\CADD_Standards\Seed Files\Design - English\i_project_2d_PowerGEOPAK.dgn  
seed file from the MoDOT workspace. 

 

 

2. Go to GEOPAK > ROAD > User Preferences, select COGO Preferences… and verify 

the Job (GPK) Directory: is set to pw:\District 

CADD\Design\Randolph\J2P0200\data_02\. 
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3. Click OK to close the COGO Preferences dialog. 

4. Click OK again to close the User Preferences dialog. 

5. Open the Coordinate Geometry dialog from the GEOPAK > ROAD > Geometry 

menu and enter the following values: 

Job: 011 

Operator Code: your initials. 

 

6. Click OK to dismiss the Coordinate Geometry dialog. 

7. Since this Coordinate geometry database does not exist, you will get the following 

message.  Select Yes in the Alert dialog to continue.  The job will hold geometry in 

native format as the civil geometry is created.  
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Create the alignment as shown per the step outlined on the following pages. 
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Creating the Tangent Elements 

1. Expand the Horizontal Geometry Toolbox in the Tasks menu. 

2.  Select Feature Definition Toggle Bar to open the toggle bar window. 

Hint: the Feature Definition Toggle Bar can be docked at the top or bottom of the screen 

so it is easily accessible. 

3. Set the active feature to Design > Design Standards > Geometry> Geometry Scratch. 

 

4.  Enable the Use Active Feature Definition tool on the Feature Definition Toggle 

bar. 

Setting an active feature definition will cause any geometry elements created to have the 

active feature assigned as its Feature Definition (property). 

5. Verify Civil AccuDraw is active. 

6.  Select the Line Between Points task from the Horizontal Geometry task group 

7. Select the XY favorite from the Civil AccuDraw toolbar. 

.  

8. Using the heads up display, key in the coordinates of the first PI (501), X = 4000            

Y = 2500. 

 

Hint: After locking in a value move the mouse to ensure the value is set. 

9. Data point to accept the point.  

10. When prompted to Enter End Point, make the Distance - Direction favorite active in 

Civil AccuDraw.  This will change the heads display.  
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11. Locate the second point (502)  with a Distance = 450 and the Direction = N59°24'00.0"E  

Hint: Directions or angles can be entered in these formats DD:MM:SS or DD^MM’SS”.  

If Bearing is the MicroStation Definition then the Alpha indicators (N S E and W) should 

be entered with no spaces before the DD and after the SS. 

 

12. Data point to accept. 

13. Place another line with a Start point (505) at X = 5192.19 and Y = 2519.20. 

14. Define the End point (504) as Distance = 360 and the Direction = N 62°28'00.0"W. 

15.  In Civil AccuDraw, make the Direction - Direction favorite active. This will find 

the intersection point based on two directions. 

16.  Select Line Between Points. 

17. Select the end of the first line (point 502) drawn above to make the compass active on the 

end point. 

Hint: To identify a civil Geometry object hover over it and let Civil AccuSnap select 

it for you  

18. Enter the first direction as S54:36:00E and tab to the next Direction field. 

19. Set the origin of the second point by typing the letter O and selecting the ending point of 

the second line (point 504). 

Note:  If presented with angle instead of direction, the Civil AccuDraw compass has 

rotated.  Key in “T” to rotate the compass to the top or “V” to rotate the compass to the 

View. 
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20. Enter the second direction as S45:32:00W and press Tab to view the solution. 

 

21. Data point in the view to accept the solution and place the line. 

22.  Select Line Between Points. 

23. AccuSnap to the end points of the first line placed (at 502) and second line placed (at 

point 504). 

 

This completes the placement of the tangent sections. The curves for Route24 will be placed 

using the Simple Arc command. 

Placing the Curves 

24. Turn off Civil AccuDraw 

25.  Select Simple Arc. 

26. Set the Trim/Extend option to Both and left-click twice to accept the solution. 

27. Enter the 243.2987 as the Radius for the first curve.  
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28. When prompted to Locate First Element, select the first tangent as noted in the graphic 

above then select the second tangent. 
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29. Data Point to accept the arc location. Data Point again to accept the Truncate Option. 

30. Repeat steps 2-6 for the second curve with a Degree of Curve using Second and Third 

Tangents shown above. Second Curve Radius is 142.2416. 

31. Repeat steps 2-6 for the third curve using Third and Fourth Tangents shown above.  Third 

Curve Radius is 147.0171. 

Complex the Elements into one Chain 

32.  Select the Complex by Elements task. 

33. Set the active feature to Design > Drafting Standards > Plan > Alignments > 

MoDOT_Baseline_Proposed. 

34. Set the Method to Automatic. 

35. Key in Route24 in the Name field. 

36. When prompted to Locate First Element, identify the beginning of the first linear element 

placed.   Note: The Arrow indicates the direction the chain will be processed. 

37. If presented with the Job Number dialog, select job011.gpk and select OK. 

 

 

 

 

 

 

Set the beginning stationing 

38.   Select the Start Station. 

39. When prompted to Locate Element, select the Route24 alignment. 

40. Set the Start Distance to 0. Data Point to accept. 

41. Enter 10+12.6 as the Start Station.  The station can be modified in the Element 

Information dialog. 

42. Verify the label for the start station has been changed to POT STA 10+12.60. 

43. Select File > Update Server Copy. 

  



GEOPAK Road 1  Chapter 2 – Civil Geometry    
 
 

5/6/16 Missouri Department of Transportation 2-43 

2.14 Group Exercise 2: Road 1 Alignment 
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Create a new MicroStation file: Civil_Geometry_ J2P0200.dgn. 

1. Click Seed and select pw:\CADD_Standards\Seed Files\Design - 

English\i_project_2d_PowerGEOPAK.dgn as the seed file 

2. Save the new file to the following location: 

Randolph\data_02\Civil_Geometry_ J2P0200.dgn. 

Note:  You may need to Check In Route24.dgn when creating the new file 

3. Reference the existing Terrain model by selecting Reference File > Tools > Attach.  

Select Terrain_J2P0200_Existing.dgn and set the attachment method as Coincident 

World. 

4. Click OK. Dismiss the Reference file dialog. 

5. Select Fit View. 

6. Create a new GPK using job number 200 and save it to ProjectWise as job200.gpk.  

Use the Civil Geometry tools and follow the steps below to create the alignments as shown on the 

previous page. 

 

Road1 

Beginning Point: X = 1,676,792.0050 Y = 1,260,393.1372 

Ending Point:  X = 1,679,002.6087 Y = 1,257,759.8897 

Beginning station of Road1 is 0+00.00. 

 

Curve Data 
 

 Direction Back  = S 24° 20’ 00.0” E 

 Degree of Curve  = 1° 45’ 00” 

 Direction Ahead  = S 52° 30’ 00.0” E 

7. Set the active feature to: 

Design > Design Standards > Geometry > Geometry Scratch. 

8. Toggle On Use Active Feature Definition. 

9. Toggle Civil AccuDraw to active. 

10. Pin the Task Menu and expand the Horizontal Geometry Toolbox. 

11. Use the “Line Between Points” tool along with Civil AccuDraw to place two lines that 

represent the two tangent sections of the Road1 alignment.  Make sure these two lines are 

long enough so that they overlap each other.  What we are attempting to do is locate the 
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overall PI location of the Spiral-Curve-Spiral using the intersection of the two Civil 

Geometry Lines. 

a. Select the “Line Between Points” tool, and using Civil AccuDraw and it’s XY 

function, key in the coordinates X = 1,676,792.0050, Y = 1,260,393.1372 

b. Once the start of the alignment has been defined, continue to place the line using 

Civil AccuDraw and its Distance-Direction option at a bearing of S 24° 20’ 00.0” E 

at a length that would extend past the PI location of the Curve (a length of at least 

1,750 feet will work).  When typing in a bearing use a colon “:” in-between the 

Degrees:Minutes and Minutes:Seconds.  For this step you would type S24:20E 

Note:  If “Angle” is display instead of “Bearing” in the Civil AccuDraw heads-up 

display select the keyboard keys “R” and then “T”.  This is a Civil AccuDraw 

shortcut to Rotate the compass to the Top view. 

c. Select the “Line Between Points” tool, and using Civil AccuDraw and it’s XY 

function, key in the coordinates X = 1,679,002.6087, Y = 1,257,759.8897 

d. Once the end of the alignment has been defined, continue to place the line using Civil 

AccuDraw and its Distance-Direction option at a bearing of N 52° 30’ 00.0” W at a 

length that would extend past the PI location of the Curve (a length of at least 2,500 

feet will work).  When typing in a bearing use a colon “:” in-between the 

Degrees:Minutes and Minutes:Seconds.  For this step you would type N52:30W. 

Note:  If “Angle” is display instead of “Bearing” in the Civil AccuDraw heads-up 

display select the keyboard keys “R” and then “T”.  This is a Civil AccuDraw 

shortcut to Rotate the compass to the Top view. 

12. Deactivate Civil AccuDraw. 

13. Next store the Curve by selecting the Simple-Arc tool, and defining the tool with the 

following parameters: 

Degree of Curve  = 1° 45’ 00” 

Notes:  

o To switch from Radius to Degree of Curve or vise-versa type in a “d” in the 

Radius field and then add the degree of curve value.   

o When typing in a Degree of Curve use a colon “:” and place in-between the 

Degrees:Minutes and Minutes:Seconds.  For this example you would type          

d 1:45:00 or d 1:45 for short. 

Once the tool is defined with the correct parameters select each tangent and place the 

Spiral-Curve-Spiral trimming both tangents back. 

14. Select Create Complex Element and to turn the individual element into one complex 

element.  Name the complex element “Road1” with no spaces.  Make sure the stationing 

will be flowing (getting larger) in a southerly direction. 

15. Using the “Start Station” tool set the Beginning Station to 0+00.00. 

16. Make sure the MicroStation Drawing Scale is set to 1”=50’. 
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17. Set the active feature to Design > Drafting Standards > Plan > Alignments > MoDOT 

Baseline Proposed. 

a. IF prompted select the 200 gpk. 

18. Generate a Horizontal Geometry Report by “left clicking” on the alignment and 

selecting from the heads up menu the Horizontal Geometry Report Tool. 

a. Verify in the Report that the geometry is correct. 

19. Select File > Update Server Copy.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



GEOPAK Road 1  Chapter 2 – Civil Geometry    
 
 

5/6/16 Missouri Department of Transportation 2-47 

2.15 Individual Exercise 3: Route63 Alignment 

Route 63  
 

Beginning Point: X = 1,676,434.4103 Y = 1,262,365.4715 

Ending Point:  X = 1,678,994.1614 Y = 1,257,205.0288 

 

Beginning station of RTE63 is 9+50.00. 

Spiral-Arc-Spiral Information 

Direction Back   = S 0° 20’ 19.8” E 

Length of the back spiral  = 200’ 

Degree of Curve   = 2° 30’ 00” 

Length of the ahead spiral  = 200’ 

Direction Ahead   = S 45° 39’ 27.2” E 

1. Set the active feature to: 

Design > Drafting Standards > Geometry > Geometry Scratch. 

2. Toggle On Use Active Feature Definition. 

3. Toggle Civil AccuDraw to active. 

4. Pin the Task Menu and expand the Horizontal Geometry Toolbox. 

5. Use the “Line Between Points” tool along with Civil AccuDraw to place two lines that 

represent the two tangent sections of the Route 63 alignment.  Make sure these two lines 

are long enough so that they overlap each other.  What we are attempting to do is locate 

the overall PI location of the Spiral-Curve-Spiral using the intersection of the two Civil 

Geometry Lines. 

a. Select the “Line Between Points” tool, and using Civil AccuDraw and it’s XY 

function, key in the coordinates X = 1,676,434.4103, Y = 1,262,365.4715 

b. Once the start of the alignment has been defined, continue to place the line using 

Civil AccuDraw and its Distance-Direction option at a bearing of S 0° 20’ 19.8” E 

at a length that would extend past the Overall PI location of the Spiral-Curve-Spiral (a 

length of at least 4,000 feet will work).  When typing in a bearing use a colon “:” in-

between the Degrees:Minutes and Minutes:Seconds.  For this step you would type 

S0:20:19.8E 

Note:  If “Angle” is display instead of “Bearing” in the Civil AccuDraw heads-up 

display select the keyboard keys “R” and then “T”.  This is a Civil AccuDraw 

shortcut to Rotate the compass to the Top view. 
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c. Select the “Line Between Points” tool, and using Civil AccuDraw and it’s XY 

function, key in the coordinates 1,678,994.1614 Y = 1,257,205.0288 

d. Once the end of the alignment has been defined, continue to place the line using Civil 

AccuDraw and its Distance-Direction option at a bearing of N 45° 39’ 27.2” W at a 

length that would extend past the Overall PI location of the Spiral-Curve-Spiral (a 

length of at least 4,000 feet will work).  When typing in a bearing use a colon “:” in-

between the Degrees:Minutes and Minutes:Seconds.  For this step you would type 

N45:39:27.2W 

Note:  If “Angle” is display instead of “Bearing” in the Civil AccuDraw heads-up 

display select the keyboard keys “R” and then “T”.  This is a Civil AccuDraw 

shortcut to Rotate the compass to the Top view. 

6. Deactivate Civil AccuDraw. 

7. Next store the Spiral-Arc-Spiral by selecting the Spiral-Arc-Spiral tool, and defining 

the tool with the following parameters: 

Length of the back spiral   = 200’ 

Degree of Curve    = 2° 30’ 00” 

Length of the ahead spiral  = 200’ 

 

Notes:  

 To switch from Radius to Degree of Curve or vise-versa type in a “d” in the Radius 

field and then the degree of curve value.   

 When typing in a Degree of Curve use a colon “:” and place in-between the 

Degrees:Minutes and Minutes:Seconds.  For this example you would type d 2:30:00 or 

d 2:30 for short. 

 

Once the tool is defined with the correct parameters select each tangent and place the 

Spiral-Curve-Spiral trimming both tangents back. 

8. Select Create Complex Element and to turn the individual element into one complex 

element.  Name the complex element “Route63” with no spaces.  Make sure the 

stationing will be flowing (getting larger) in a southerly direction. 

a. IF prompted select the 200 gpk. 

9. Using the “Start Station” tool set the Beginning Station to 9+50.00. 

10. Make sure the MicroStation Drawing Scale is set to 1”=50’. 

11. Set the active feature to Design > Drafting Standards > Plan > Alignments > MoDOT 

Baseline Proposed. 

a. IF prompted select the 200 gpk. 
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12. Generate a Horizontal Geometry Report by “left clicking” on the alignment and 

selecting from the heads up menu the Horizontal Geometry Report Tool. 

a. Using the report verify the Beginning and Ending coordinates are correct to 4 decimal 

places. 

13. Select File > Update Server Copy.  
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2.16  Individual Exercise 3 (Optional): B1 

1. Create a new MicroStation file named B1.dgn 

2. Use the Civil Geometry tools to create chain B1 as shown below.  Verify the area of the 

chain. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hints: 

 Angles at 604 and 605 are not 90 

 

 The tanget lengths of 1,500 and 900 are distances from the point of Curvature. 

 

Store as a Complex Linear Element and verify the area by “left clicking” on the new 

alignment and selecting from the heads up menu the Horizontal Geometry Report tool.  

Use a report called Horizontal Alignment Area to get the area of the alignment. 

 


