Chapter 1

Introduction to the Terrain Model

1.1 Objectives ........................................................................................................ 1-1
1.2 Definitions ........................................................................................................ 1-1
1.3 Terrain Model as a MicroStation Element ..................................................... 1-1
1.4 Terrain Models and Feature Definition .......................................................... 1-1
  1.4.1 Applying an Feature Definition to a Terrain Model .................................. 1-1
1.5 Referencing Terrain Models ........................................................................... 1-3
1.6 Overview of Civil Terrain Model .................................................................. 1-5
1.7 Terrain Model Features .................................................................................. 1-5
  1.7.1 Spot or Spot Elevation ............................................................................. 1-5
  1.7.2 Break Lines .............................................................................................. 1-6
  1.7.3 Soft Break Line ....................................................................................... 1-6
  1.7.4 Graphic Break Line ................................................................................ 1-6
  1.7.5 Contour .................................................................................................... 1-6
  1.7.6 Hole .......................................................................................................... 1-7
  1.7.7 Boundary .................................................................................................. 1-7
  1.7.8 Drape Boundary ..................................................................................... 1-8
  1.7.9 Voids ....................................................................................................... 1-8
  1.7.10 Drape Void ............................................................................................ 1-8
  1.7.11 Break Void ............................................................................................ 1-9
  1.7.12 Islands ................................................................................................... 1-9
1.8 Triangulation Options - Edge Method ............................................................ 1-10
1.9 Terrain Models in Element Information ......................................................... 1-11
  1.9.1 General .................................................................................................... 1-11
  1.9.2 Extended .................................................................................................. 1-12
  1.9.3 Information ............................................................................................... 1-12
  1.9.4 Edge Method ........................................................................................... 1-12
  1.9.5 Calculated Features .............................................................................. 1-13
  1.9.6 Source Features Display ....................................................................... 1-13
  1.9.7 Feature .................................................................................................... 1-14
1.10 Terrain Model Create Toolset ..................................................................... 1-14
1.11 Individual Exercise: J2P0200 Terrain Model ............................................. 1-17
1.1 Objectives

- Understand what is a Civil Terrain Model
- Learn how to import a Civil Terrain Model from a .tin
- Learn how to display a Civil Terrain Model

1.2 Definitions

A Terrain Model is a set of three-dimensional triangles mathematically computed from point data collected on the surface being modeled. Models are used to define highly irregular surfaces, particularly the surface of the earth, but can be generated for proposed surfaces, subsurface geotechnical layers, and etcetera. Terrain models are also referred to as digital terrain models (DTMs), triangulated irregular networks (TINs), or triangulated surfaces.

The MicroStation Terrain Model tools support importing and labeling terrain contours and spots on terrain models. You can import a terrain model into a DGN to use its data. Terrain models imported from the LandXML file format are supported within MicroStation. However, any manipulation or importing from Civil products must be done within Bentley Civil.

1.3 Terrain Model as a MicroStation Element

A terrain model is recognized as a MicroStation element type as of MicroStation V8i (SELECTseries 4). When you select a terrain model, the Element Selection tool Element Type tab indicates that it is a Terrain element type.

1.4 Terrain Models and Feature Definition

The display of terrain model properties can be controlled by using a feature definition. You can apply it to any terrain model.

1.4.1 Applying an Feature Definition to a Terrain Model

1. Open the MicroStation file where the terrain model was created.

2. Use the Element Selection tool to select the terrain model.
3. In the Heads-up display toolbox, select Properties.

4. Or select the Element Information tool.
5. On the General tab click the arrow to the right of the Template property and select an element template.

The properties of the selected element template are applied to the terrain model.

### 1.5 Referencing Terrain Models

People in different job roles may want to see terrains displayed differently. For example, a designer of surfaces may need to see triangles, while a designer of drainage features may need to see contours. Rather than duplicating the terrain model in various places, the best workflow is to maintain a single terrain model and reference it into other DGN files.

When a DGN file containing a terrain model is referenced into another DGN file, you can allow the terrain model to be displayed differently in the other file. This allows the presentation to vary for different purposes, without changing the terrain model display in the original DGN file.

**To Override the Symbology of a Terrain Model**

1. Attach as a reference the DGN file containing the terrain model by selecting the References icon from the Primary Tools.
2. Select the terrain element from the MicroStation view.

3. From the Primary Tools toolbox, select the Element Information tool. The Element Information dialog opens.

4. On the Reference tab set the Override Symbology property to Yes.

5. Change other display properties as needed or select an element template to apply to the terrain model.

The display of the terrain model changes in your DGN file according to these settings, but not in the original DGN file.
1.6 Overview of Civil Terrain Model

Terrains Models (TM) play a key role in Infrastructure and Mapping workflows. The data collection methods underlying these models are ever increasing in detail and coverage. Therefore, resulting terrains need to be accessible across a variety of Infrastructure and Mapping workflows.

Data in a variety of formats including raw graphical elements 2D and 3D can be provided for consumption into the terrain model. The existing ground terrain model can also be used as the starting point for the creation of a proposed design terrain model using the Corridor Modeling tools.

1.7 Terrain Model Features

The concept of feature types is used throughout the Terrain Model tools. The available feature types are defined below.

1.7.1 Spot or Spot Elevation

Points (with X, Y, Z data) that have no functional relationship to any other point. Random survey shots in open terrain would be an example of random spots. Point elements such as cells, circles, and text strings are typical MicroStation elements used to graphically define spot elevations, lines, line strings, and other longitudinal elements are equally valid. The software creates a spot elevation for each vertex of each longitudinal element.

If a section is cut through this digital terrain model at the location A-A, where the elevation of the triangle leg as linearly interpolated between the triangle vertices is plotted along the distance of the section, the section would look as shown in the picture below.
1.7.2 Break Lines

Breaks are used to designate linear features such as edges of pavement, ditch bottoms, ridges, etcetera where an abrupt change of slope occurs. Any longitudinal element may be defined as a break line. Triangles will not cross a break line in the terrain model.

Adding a break line to the same set of points (used in the above illustration) will produce the terrain model as shown below.

![Break Lines Diagram]

Cutting a section at the same location will produce very different results as shown in the section below.

1.7.3 Soft Break Line

A soft break line is a break line; however, if it crosses a break line, it will not affect the triangulation and is ignored. This feature type is not frequently used. It can be used during survey collection to identify a feature that is a breakline, but is known to cross another break line, resulting in crossing break lines.

1.7.4 Graphic Break Line

A graphic break line is a soft break line that is not stored in the terrain model. This feature type is not frequently used.

1.7.5 Contour

A contour is an element or set of elements of the same elevation. Contours may be used as source data to generate a terrain model, or may be computed (drawn based on terrain model). For example, you may want to create a terrain model from digitized contours from an old plan.
1.7.6 Hole

An area defined by a closed shape that demarcates a region where the current terrain is ignored and the underlying terrain is utilized. For example, holes can be used for marking areas where you would not want to disturb during a design.

1.7.7 Boundary

A boundary is the maximum external limits a terrain model can extend. No triangles will be created outside of this boundary. For example, a boundary can be changed on a terrain model by deleting triangles or changing the Edge Method. A new boundary can be added to an existing terrain model using the Add Features command.
1.7.8 Drape Boundary

A drape boundary is a surface boundary that determines its elevations by draping on the underlying surface. For example, you may use a drape boundary to limit the extent of the triangles by drawing the boundary as an element, using the Add Features command to add the boundary to the terrain model. The new boundary would use the elevations of the underlying surface as the boundary elevations.

1.7.9 Voids

An area defined by a closed shape that demarcates a region of missing data or obscure areas. No point or break data located within the void area is utilized and no triangles are created inside the void areas. The Void coordinates are included in the triangulation and void lines between successive void coordinates are inserted as drape lines on the surface. Therefore, they do not change the slope or elevations of the surface.

1.7.10 Drape Void

An area defined by a closed shape that demarcates a region of missing data or obscure areas. No point or break data located within the void area is utilized and no triangles are created inside the void areas. In the drape void, the void coordinates are not included in the triangulation. Voids are inserted post triangulation. The void coordinates and lines are draped on the terrain model surface. Even though a user must provide an elevation for Drape Void vertices, the user elevations are changed to the elevation of the terrain model surface at the XY Drape Void coordinate position. For example, if you don’t have accurate survey data for the void area, you may want to use the drape void.
1.7.11 Break Void

An area defined by a closed shape that demarcates a region of missing data or obscure areas. No point or break data located within the void area is utilized and no triangles are created inside the void areas. It differs from Voids and Drape Voids in that it utilizes the vertex elevations of the graphical element, while the void lines between successive void coordinates are inserted as break lines. Therefore, break voids change the slope and elevations of the surface. For example, if you have accurate survey data for the void area, you may want to use a break void. These could be used for surveyed building footprints or ponds where the points have been accurately surveyed.

1.7.12 Islands

An area defined by a closed shape that demarcates a region of data wholly within a void. Example, islands in the middle of rivers, lakes, etcetera.
Chapter 1 – Introduction to the Terrain Model  GEOPAK Road 1

1.8 Triangulation Options - Edge Method

Several of the terrain model tools utilize the triangulation options section where the Edge Method is specified.

Many of the external edge triangles are thin and narrow and not representative of the surface. This is particularly evident where the edge of the data set is concave in nature. One approach to eliminate these triangles is the use of the Edge Method.

The Edge Method defines which triangles around the edge of a Terrain Model get created.

There are two options to control the edge triangles. The terrain model is updated dynamically when the Edge Method changes so if the results are not acceptable, change the value until the results are acceptable. Only triangles along the edge of a terrain model are affected by this parameter. Interior triangles are never removed.

There are three settings for the Edge Method option: None, Remove Slivers, and Max Triangle Length.

None - No external triangles are deleted. Note the Maximum Triangle Side Length is ignored. There are no user defined parameters

Slivers - Long, thin triangles are dissolved based on a formula hard coded within the software. Note the Maximum Triangle Side Length is ignored. There are no user defined parameters.

Max Triangle Length - External triangles whose external edge is longer in length than the user specified distance are deleted. Note the maximum length does not apply to internal triangles, only those on the edge of the model. Specify the Maximum Triangle Length in master units.
1.9 Terrain Models in Element Information

As a terrain model is a MicroStation element, a wealth of information can be found in the Element Information dialog. One important option is display on/off of terrain model features. For example, you can turn on and off the display of the contours, triangles, and voids.

The element information can be accessed by selecting Element > Information off of the menu or by selecting the properties option from the context sensitive toolbar that pops up when the mouse hovers over an element when the Element Selection tool is active.

The element information can be accessed by selecting Element > Information off of the menu. Some of the items in the Element Information dialog are informational and cannot be changed. Some of the items can only be changed if you are in the MicroStation file that contains the Terrain Model. Following are descriptions of the functionality of each tab in the Element Information dialog.

1.9.1 General

This displays the terrain model Description and Name. It also identifies the display symbology of the terrain model. The symbology is only used if the Feature Definition was not defined during the creation of the terrain model. You can also select a Template in order to change the display of the terrain model within the General tab.
1.9.2 Extended

Allows you to set the terrain to Snapable or Not Snapable, Lock or Unlock the terrain, and view the model it is in, its creation date, and the modification state of the terrain.

1.9.3 Information

Lists the X, Y, Z range of the selected terrain model. In addition, it has the number of each type of source features, i.e., the number of points, voids, or break lines.

1.9.4 Edge Method

This displays the Edge Method used when creating the terrain model.
1.9.5 Calculated Features

Turns the display off or on for any data in the terrain model that is not source data. Example, triangles, high points, low points, and flow arrows. The change is immediately visible on the screen, it is not necessary to exit the file and re-enter.

1.9.6 Source Features Display

Turns the display off or on for any data that was used to create the terrain model. The change is immediately visible on the screen, it is not necessary to exit the file and re-enter.
1.9.7 Feature

Element Information will list the feature name and feature definition of the selected terrain model.

Quick Properties of Terrain Models

Selecting the terrain model using the Element Selection tool and clicking on Properties opens the terrain model Properties pop-up where you can set the maximum triangle length, turn on/off various graphical features and change the feature name and definition.

1.10 Terrain Model Create Toolset

**Terrain Model Create** - Contains tools to create a terrain model from graphical elements, ASCII files, point clouds, LandXML, and import existing surface files. Tools are also available to merge two or more models together and/or to clip models.
Create From File creates a Terrain Model by importing an existing digital terrain model file. The file types supported include the GEOPAK .tin and .dat file types. Import options include Import Terrain Only, Import Features Only and Import Both. Importing features only writes the features to the design file as MicroStation graphics not tied to the Terrain Model.

Create Terrain Model from ASCII File creates a terrain model by importing from an ASCII file type using customized user file formats.

Create Terrain Model by Graphical Filter is an automated way of storing search settings for graphic elements to automate Create Terrain Model by Filter Elements. Uses the settings stored by Graphical Filter Manager to create the terrain. The Graphic Filter Manager icon is located in the Terrain Model tasks group.

Create from Point Cloud creates a terrain model from MicroStation Point Cloud data. The Point Cloud has to be attached to the dgn prior to being able to create a Terrain Model.

1. Select MicroStation File >Point Clouds.
2. Select File > Attach.

Create from Elements creates a terrain model from 3D graphical elements. The elements can be in a reference file.

Create Complex Terrain Model creates a new Complex terrain model by merging/appending multiple terrain models.

Create Clipped Terrain Model creates a terrain model by clipping an existing terrain model and providing an optional horizontal or vertical offset.
Create Delta Terrain Model creates a new terrain model using the difference between 2 terrain models or a terrain model and a plane (elevation). Vertical offsets can be assigned to the Terrain Models in the Terrain Model to Terrain Model method.

Create Terrain by Text Level Interpolation creates a terrain model from 2D graphics which also contain an elevation label.

Create Corridor Alternate Surfaces is used to manage alternate surfaces in the template. This command is useful for the generation of surfaces to be exported to Automated Machine Control LandXML files.
1.11 Individual Exercise: J2P0200 Terrain Model

1. Within the `data_0\data` folder, open the file: `Introduction_To_Terrain_Models.dgn`

2. Select `File > New` and create a new MicroStation file using the `Source File`:
   `pw:\CADD_Standards\Seed Files\Design - English\i_project_3d_PowerGEOPAK.dgn`
   
   **Note:** If this is not the default seed file, use the `Seed...` button to locate this seed file in the Projectwise.

3. Key in the new file name `Terrain_J2P0200_Existing.dgn`. This will be the existing ground file for the project. It will be created in project wise.

4. In the `Folder` section, save the file to the folder `Data`

5. Select `OK`.

6. Check in the file `Introduction_To_Terrain_Models.dgn`.

7. Expand the `Terrain Model` Tasks group.

8. Select `Create From File` icon.
9. In the Select Files To Import dialog select: J2P0200.tin
10. Click Add and OK. This will bring up the Import Terrain Model(s) dialog.
11. In the Filter section, set the Source File Units to US Survey Feet.
12. Set the Feature Definition to Feature Definition > Existing Triangles.
13. Set the Import Options to Import Terrain Only.
14. Click Import and close the Import Terrain Model(s) dialog.
15. Fit the view.
16. Select the Element Selection tool.
17. Data point on the boundary of the Terrain Model and wait for the context sensitive menu to appear.
18. Select *Properties*.

19. Change the *Edge Method* to **Max. Triangle Length**. Set the *Length* to **150.00**.

20. **Toggle On and Off** the *Source Feature Display* items such as *Contours, Triangles, etc.* and review the display.

21. **Turn Off** the *Source Feature Display* items.

22. Open the Project Explorer select the **Civil Model** tab.

23. Expand the **Civil Data > Terrain_J2P0200_Existing.dgn > Terrain Models** folders.

24. Expand the **Terrain Model** leaf. Notice that it has the source file information.

25. Right-click on the **Terrain Model:J2P0200** and review the options in the pop-up menu.

26. Select **Element Information** and review. Here is where the terrain model can be renamed, a new feature definition assigned, and feature display turned on/off.
27. Expand the Feature Field and set the Feature Definition to *Existing Contours 10-2*.

![Element Information Dialog](image)

28. At the top of the Element Information Dialog expand the **Calculated Features Display** leaf and select **Contours**. Adjust the **Major and Minor** Intervals to **5 and 1**.

![Contours](image)

29. Data point on the boundary of the Terrain Model and wait for the context sensitive menu to appear.

![Properties](image)
30. Select Properties.

31. Set the Feature Definition to Feature Definition > Existing Boundary.

32. Select File > Update Server Copy.